maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander <the.malk...@gmail.com>
Subject Re: Dependency of different version
Date Mon, 26 Oct 2009 08:11:03 GMT
Thank you, Stevo! Used com.google.jarjar:1.0 and successfully repacked A
project. Thanks God its open source!

2009/10/25 Stevo Slavić <sslavic@gmail.com>

> http://asm.ow2.org/doc/faq.html#Q15
>
> Regards,
> Stevo.
>
> On Sun, Oct 25, 2009 at 6:24 PM, Alexander <the.malkolm@gmail.com> wrote:
>
> > Great, anything else?
> >
> > 2009/10/25 Stevo Slavić <sslavic@gmail.com>
> >
> > > OSGi. See versioning in list of benefits here<
> > > http://www.osgi.org/About/WhyOSGi>
> > > .
> > >
> > > Regards,
> > > Stevo.
> > >
> > > On Sun, Oct 25, 2009 at 5:08 PM, Alexander <the.malkolm@gmail.com>
> > wrote:
> > >
> > > > Hello all,
> > > >
> > > > My project has two dependencies A and B.
> > > >
> > > > A - has asm:2.2.3 as dependency.
> > > > B - has asm:1.5.3 as dependency.
> > > >
> > > > Its invalid to use asm:2.2.3 in B and asm:1.5.3 in A. (lot of error
> > > occurs)
> > > >
> > > > How could I make both A and B use their favourite asm version?
> > > >
> > > > --
> > > > Regards,
> > > > Alexander
> > > >
> > >
> >
> >
> >
> > --
> > Regards,
> > Alexander
> >
>



-- 
Regards,
Alexander

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message