maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <stephen.alan.conno...@gmail.com>
Subject Re: AW: How to specify a plugin version from the command line?
Date Thu, 17 Sep 2009 08:44:09 GMT
plugin management of current pom or any of its parents

2009/9/17 Lewis, Eric <Eric.Lewis@ipi.ch>:
> Ok, that's no problem, but can I specify somewhere that Maven should at least take version
x for plugin y?
>
> Best regards,
> Eric
>
>> -----Ursprüngliche Nachricht-----
>> Von: Stephen Connolly [mailto:stephen.alan.connolly@gmail.com]
>> Gesendet: Donnerstag, 17. September 2009 10:41
>> An: Maven Users List
>> Betreff: Re: AW: How to specify a plugin version from the
>> command line?
>>
>> version ranges are not supported for plugins
>>
>> 2009/9/17 Lewis, Eric <Eric.Lewis@ipi.ch>:
>> > Hmmm...
>> >
>> > This works:
>> > mvn org.apache.maven.plugins:maven-help-plugin:2.1:describe
>> -Dplugin=help
>> >
>> > This doesn't work:
>> > mvn
>> org.apache.maven.plugins:maven-help-plugin:[1.0,2.1):describe
>> -Dplugin=help
>> >
>> > Best regards,
>> > Eric
>> >
>> >> -----Ursprüngliche Nachricht-----
>> >> Von: Martin Gainty [mailto:mgainty@hotmail.com]
>> >> Gesendet: Mittwoch, 16. September 2009 17:36
>> >> An: users@maven.apache.org
>> >> Betreff: RE: AW: How to specify a plugin version from the
>> >> command line?
>> >>
>> >>
>> >> try [1.0,2.0)
>> >>
>> >> version 1.0 <= x < 2.0 inclusive
>> >>
>> >> http://docs.codehaus.org/display/MAVEN/Dependency+Mediation+an
>> >> d+Conflict+Resolution#DependencyMediationandConflictResolution
>> >> -DependencyVersionRanges
>> >>
>> >> Martin Gainty
>> >> ______________________________________________
>> >> Verzicht und Vertraulichkeitanmerkung/Note de déni et de
>> >> confidentialité
>> >>
>> >> Diese Nachricht ist vertraulich. Sollten Sie nicht der
>> >> vorgesehene Empfaenger sein, so bitten wir hoeflich um eine
>> >> Mitteilung. Jede unbefugte Weiterleitung oder Fertigung einer
>> >> Kopie ist unzulaessig. Diese Nachricht dient lediglich dem
>> >> Austausch von Informationen und entfaltet keine rechtliche
>> >> Bindungswirkung. Aufgrund der leichten Manipulierbarkeit von
>> >> E-Mails koennen wir keine Haftung fuer den Inhalt uebernehmen.
>> >> Ce message est confidentiel et peut être privilégié. Si vous
>> >> n'êtes pas le destinataire prévu, nous te demandons avec
>> >> bonté que pour satisfaire informez l'expéditeur. N'importe
>> >> quelle diffusion non autorisée ou la copie de ceci est
>> >> interdite. Ce message sert à l'information seulement et
>> >> n'aura pas n'importe quel effet légalement obligatoire. Étant
>> >> donné que les email peuvent facilement être sujets à la
>> >> manipulation, nous ne pouvons accepter aucune responsabilité
>> >> pour le contenu fourni.
>> >>
>> >>
>> >>
>> >>
>> >> > From: Eric.Lewis@ipi.ch
>> >> > To: users@maven.apache.org
>> >> > Date: Wed, 16 Sep 2009 17:25:33 +0200
>> >> > Subject: AW: How to specify a plugin version from the
>> command line?
>> >> >
>> >> > Hi Martin
>> >> >
>> >> > Thanks, that works.
>> >> >
>> >> > However, it's not really elegant  ;-)
>> >> >
>> >> > Is there a way to nail the plugin versions somewhere in the
>> >> configuration? If possible with version ranges, like [2.3)
>> >> >
>> >> > Best regards,
>> >> > Eric
>> >> >
>> >> > > -----Ursprüngliche Nachricht-----
>> >> > > Von: Martin Gainty [mailto:mgainty@hotmail.com]
>> >> > > Gesendet: Mittwoch, 16. September 2009 17:21
>> >> > > An: users@maven.apache.org
>> >> > > Betreff: RE: How to specify a plugin version from the
>> >> command line?
>> >> > >
>> >> > >
>> >> > > Eric
>> >> > >
>> >> > > did you try running mvn with groupId:artifactId:version:goal
>> >> > > at command line e.g.
>> >> > > mvn
>> >> > > PlugIngroupID:PlugInartifactID:PlugInversion:goalhttp://maven.
>> >> > > apache.org/guides/plugin/guide-java-plugin-development.html
>> >> > > Martin Gainty
>> >> > > ______________________________________________
>> >> > > Verzicht und Vertraulichkeitanmerkung/Note de déni et de
>> >> > > confidentialité
>> >> > >
>> >> > > Diese Nachricht ist vertraulich. Sollten Sie nicht der
>> >> > > vorgesehene Empfaenger sein, so bitten wir hoeflich um eine
>> >> > > Mitteilung. Jede unbefugte Weiterleitung oder Fertigung einer
>> >> > > Kopie ist unzulaessig. Diese Nachricht dient lediglich dem
>> >> > > Austausch von Informationen und entfaltet keine rechtliche
>> >> > > Bindungswirkung. Aufgrund der leichten Manipulierbarkeit von
>> >> > > E-Mails koennen wir keine Haftung fuer den Inhalt uebernehmen.
>> >> > > Ce message est confidentiel et peut être privilégié. Si vous
>> >> > > n'êtes pas le destinataire prévu, nous te demandons avec
>> >> > > bonté que pour satisfaire informez l'expéditeur. N'importe
>> >> > > quelle diffusion non autorisée ou la copie de ceci est
>> >> > > interdite. Ce message sert à l'information seulement et
>> >> > > n'aura pas n'importe quel effet légalement obligatoire. Étant
>> >> > > donné que les email peuvent facilement être sujets à la
>> >> > > manipulation, nous ne pouvons accepter aucune responsabilité
>> >> > > pour le contenu fourni.
>> >> > >
>> >> > >
>> >> > >
>> >> > >
>> >> > > > From: Eric.Lewis@ipi.ch
>> >> > > > To: users@maven.apache.org
>> >> > > > Date: Wed, 16 Sep 2009 17:11:46 +0200
>> >> > > > Subject: How to specify a plugin version from the
>> command line?
>> >> > > >
>> >> > > > Hi
>> >> > > >
>> >> > > > I'm setting the exact versions for all Maven plugins in our
>> >> > > company-wide parent POM.
>> >> > > > However, that doesn't help when I'm using the command line.
>> >> > > > So how can I force Maven to use a certain version of
>> a plugin?
>> >> > > >
>> >> > > > Best regards,
>> >> > > > Eric
>> >> > > >
>> >> > >
>> >>
>> ---------------------------------------------------------------------
>> >> > > > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> >> > > > For additional commands, e-mail: users-help@maven.apache.org
>> >> > > >
>> >> > >
>> >> > >
>> _________________________________________________________________
>> >> > > Hotmail: Free, trusted and rich email service.
>> >> > > http://clk.atdmt.com/GBL/go/171222984/direct/01/
>> >> >
>> >>
>> ---------------------------------------------------------------------
>> >> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> >> > For additional commands, e-mail: users-help@maven.apache.org
>> >> >
>> >>
>> >> _________________________________________________________________
>> >> Ready for Fall shows? Use Bing to find helpful ratings and
>> >> reviews on digital tv's.
>> >> http://www.bing.com/shopping/search?q=digital+tv's&form=MSHNCB
>> >> &publ=WLHMTAG&crea=TEXT_MSHNCB_Vertical_Shopping_DigitalTVs_1x1
>> >
>> ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> > For additional commands, e-mail: users-help@maven.apache.org
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: users-help@maven.apache.org
>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message