maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Randall <javabr...@gmail.com>
Subject Re: assist request with missing m2eclipse dependency
Date Sun, 05 Jul 2009 10:42:53 GMT
Hi Tony,

I'm not sure what the bundle type is that you are referencing, but I 
think if you remove that and pick up the default jar it will work.

Best
Brett

tony_k wrote:
> i'll preface this with the fact that i'm new to maven and m2eclipse, so
> forgive me if i'm being dense,
> but i'm just trying to build a java project in eclipse/galileo using the
> m2eclipse plugin,
> and i'm specifying the dependency:
> Code:
>
>     <dependency>
>     	<groupId>org.springframework.security</groupId>
>     	<artifactId>spring-security-core</artifactId>
>     	<version>2.0.4</version>
>     	<type>bundle</type>
>     	<scope>compile</scope>
>     </dependency>
>
> and i'm getting:
>
> Quote:
> Missing artifact
> org.springframework.security:spring-security-core:bundle:2.0.4:compile
>
> - the spring-security-core-2.0.4 pom and jar artifacts are in the
> appropriate dir in my local .m2 tree
> (org/springframework/security/spring-security-core/2.0.4)
>
> - could this be an m2eclipse/maven issue, something having to do with
> "bundle" packaging, both or neither?
>
> - could it be a misleading error message where it's really an issue with one
> of the myriad transitive dependencies but it's not telling me which one is
> the issue?
>
> any guidance appreciated...
>
> thx,
> tony. 
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message