maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wayne Fay <wayne...@gmail.com>
Subject Re: follow to: problem upgrading from maven 2.0.9 to 2.1
Date Tue, 09 Jun 2009 19:35:01 GMT
Proxy issues are, by their very nature, almost impossible for an
outsider to investigate and resolve. There are literally hundreds (or
more) of proxy server software packages in the world, and while they
all more or less work for basic web browsing, most have issues with
various pieces of software like Maven.

I won't claim to know all the changes made to the Maven codebase from
2.0.9 to 2.1.0 (much less the changes in supporting utility libraries)
but it would seem that some change has caused your proxy to stop
working. If you seriously want to see this resolved, it will probably
take some effort on your part to get Maven and all its libraries
running in a debugger to try to track down what is different.

Unless a ton of people start complaining about similar problems or the
issue can be tracked to a specific change made in Maven (or a util
library), I don't see this being resolved in any well-defined
timeframe.

So, I'd stick with 2.0.9 for now. Have you tried 2.0.10 yet?

Wayne

On Tue, Jun 9, 2009 at 12:17 PM, Robert Glover<robertgloverjr@yahoo.com> wrote:
>
>>>I believe your problem must lie within your proxy:
>
>     I was overly glib in wrongly implying this problem is recreate-able in shops where
maven 2.1.0 is working okay.  I simply meant it always happens to me at work, even when the
pom file is the simplest possible.  I agree with you that the proxy is the key to this.  However
the only control I am aware of that I have over the proxy is in settings.xml.  Below is what
I have in settings.xml.  It's the same settings.xml I use with maven 2.0.9, where it works
fine.   The proxy does not use or need a username/password, even though I specify dummies
for it in settings.xml.  I was thinking maybe that maven 2.1.0 fails because of the dummy
username/password below in settings.xml,  even though with maven 2.0.9 it does not care that
there are a dummy username/password.  I've been stumped by this for going on a month.
>     There was something in the release notes of 2.1.0 about the "active" tag in settings.xml
 being misleading, but it did not explain if anything was actually changed.
>
>  <proxies>
>    <!-- proxy
>     | Specification for one proxy, to be used in connecting to the network.
>     | -->
>    <proxy>
>      <id>optional</id>
>      <active>true</active>
>      <protocol>http</protocol>
>      <username>proxyuser</username>
>      <password>proxypass</password>
>      <host>b1web1.obfuscated.org</host>
>      <port>8080</port>
>      <nonProxyHosts>b1bsdzv03</nonProxyHosts>
>    </proxy>
>
>  </proxies>
>
>
>
> ----- Original Message ----
> From: Wayne Fay <waynefay@gmail.com>
> To: Maven Users List <users@maven.apache.org>
> Sent: Tuesday, June 9, 2009 2:58:58 PM
> Subject: Re: follow to: problem upgrading from maven 2.0.9 to 2.1
>
> I followed your directions exactly and got the following results:
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 26 seconds
> [INFO] Finished at: Tue Jun 09 11:56:19 PDT 2009
> [INFO] Final Memory: 8M/22M
> [INFO] ------------------------------------------------------------------------
>
> I believe your problem must lie within your proxy:
>> [DEBUG] Using Proxy: b1web1.obfuscated.org
>> Downloading: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.4.3/maven-surefire-plugin-2.4.3.pom
>> [DEBUG] Access denied to: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.4.3/maven-surefire-plugin-2.4.3.pom
>> org.apache.maven.wagon.authorization.AuthorizationException: Access denied to: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.4.3/maven-surefire-plugin-2.4.3.pom
>
> Wayne
>
>
> On Tue, Jun 9, 2009 at 9:53 AM, Robert Glover<robertgloverjr@yahoo.com> wrote:
>>    I've reduced the problem of why I can't upgrade from maven 2.0.9 to to 2.1.0
to it's barest essentials.
>>
>>    For my recreatable test, I am using the instructions in chapter 3 of "Maven:
The Definitive Guide" from the section "Creating a Simple Project".
>>
>>    Note as I detail the steps below that these exact same steps work perfectly
when I point M2, M2_Home, and PATH to maven 2.0.9. They fail however when I point to 2.1.0.
   Please also note that this problem is total, by which I mean that there are no situations
in which maven 2.1.0 is working, yet in all these same situations maven 2.0.9 is working okay.
 I even tried this on another developer machine which had never had maven installed on it
before, and maven 2.1.0 failed there too.
>>
>> Step one of six:  create new directory.
>> Step two of six:  open Dos window, make that directory current.
>> Step three of six:  invoke this bat file:
>>
>> set M2_HOME=C:\JavaLibs\apache-maven-2.1.0
>> set M2=C:\JavaLibs\apache-maven-2.1.0\bin
>> set PATH=C:\JavaLibs\apache-maven-2.1.0\bin;%PATH%
>>
>> step four of six)  issue this command (note: because I already did this test with
maven 2.0.9, it does not need to get anything from local repository).
>>
>> mvn archetype:create  -DgroupId=org.foo.bar -DartifactId=simple -DpackageName=org.foo.bar
>>
>> (output is shown below)
>>
>> C:\JavaLibs\aTestMaven210bX>mvn archetype:create  -DgroupId=org.foo.bar -DartifactId=simple
-DpackageName=org.foo.bar
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message