maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From huser <mpinj...@atxg.com>
Subject maven release plugin issue
Date Mon, 04 May 2009 20:24:52 GMT

Hi,

I am running maven release plugin by:

mvn -f pom.xml -Pabc.debug.release --batch-mode -Dtag=REL1.5-TEST
-DtagBase="https://abcsvn001.na.abcglobal.com/abc_repos/T3/tags"
-DreleaseVersion=1.5 -DdevelopmentVersion=1.6-SNAPSHOT release:prepare

And I get this build error.
[INFO] [INFO] An Ant BuildException has occured: The following error
occurred wh
ile executing this line:
[INFO]
C:\mvn_rel\int_002_dev_test\services-api\abc-interface-api\xsd-extract.xm
l:19: Error while expanding C:\Documents and
Settings\huser\.m2\repository\co
m\abc\t3\abc-websvc-api\1.5\abc-websvc-api-1.5.jar
[INFO] java.io.FileNotFoundException: C:\Documents and
Settings\huser\.m2\rep
ository\com\abc\t3\abc-websvc-api\1.5\abc-websvc-api-1.5.jar (The system
cannot
 find the path specified)

I do not get this error if I do not use the release plugin i.e.
mvn -f pom.xml -Pabc.debug.release clean install deploy

In my xsd-extract.xml, I have an environment variable $verinfo which 

		<unjar
src="${env.M2_REPO}/com/abc/t3/abc-websvc-api/${verinfo}/abc-websvc-api-${verinfo}.jar" 

gets its value defined in abc-interface-api

		<plugins>
			<plugin>
				<groupId>org.apache.maven.plugins</groupId>
				<artifactId>maven-antrun-plugin</artifactId>
				<executions>
					<execution>
						<id>extract-xsds</id>
						<phase>initialize</phase>
						<configuration>
<tasks>
	<property name="verinfo" value="${project.parent.version}" />
	<echo message="My dependency name: ${verinfo}" /> 
	<ant antfile="${basedir}/xsd-extract.xml">
		<target name="retrieve-xsds" />
	</ant>
</tasks>
						</configuration>
						<goals>
							<goal>run</goal>
						</goals>
					</execution>
				</executions>
</plugin>

Why is abc-websvc-api-1.5.jar being called before it is deployed in .m2 ?
This jar does get generated in abc-interface-api\target. But it does not get
deployed in .m2

Any ideas ?

thanks,
-- 
View this message in context: http://www.nabble.com/maven-release-plugin-issue-tp23375978p23375978.html
Sent from the Maven - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message