maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mick Knutson <mickknut...@gmail.com>
Subject Re: issues with profile and activeByDefault
Date Fri, 27 Feb 2009 16:14:40 GMT
With that failing, I even tried to create a property that was set to false:

       * <scm.staging>false</scm.staging>
    </properties>

    <profiles>

        <profile>
            <id>QAS</id>
            <properties>
                <scm.staging>true</scm.staging>
                <stage.dir>${user.home}/STAGING/${symphony.profile.name
}/QAS</stage.dir>
                <phase.dir>qual/${groupId}-${artifactId}/stat</phase.dir>
                <deploy.relink>false</deploy.relink>
            </properties>
        </profile>
*

*Then in my settings.xml, I use this:
*
        <profile>
            *<id>default</id>*
            <activation>
                  <property>
                      <name>scm.staging</name>
                      *<value>false</value>*
                  </property>
            </activation>

On the command line:
*mvn -PQAS clean package -e*

as well as:
*mvn clean package -e*

both result in the default profile to NOT get used.

---
Thank You…

Mick Knutson, President

BASE Logic, Inc.
Enterprise Architecture, Design, Mentoring & Agile Consulting
p. (866) BLiNC-411: (254-6241-1)
f. (415) 685-4233

Website: http://baselogic.com
Linked IN: http://linkedin.com/in/mickknutson
Twitter: http://twitter.com/mickknutson
Vacation Rental: http://tahoe.baselogic.com
---



On Fri, Feb 27, 2009 at 10:44 AM, Mick Knutson <mickknutson@gmail.com>wrote:

> I have tried all of these combination and I can not get this to work:
>
> <name>!QAS, !PRD</name>
>
> <name>!QAS & !PRD</name>
>
> <name>!QAS && !PRD</name>
>
> <name>!QAS and !PRD</name>
>
> Any ideas?
>
> ---
> Thank You…
>
> Mick Knutson, President
>
> BASE Logic, Inc.
> Enterprise Architecture, Design, Mentoring & Agile Consulting
> p. (866) BLiNC-411: (254-6241-1)
> f. (415) 685-4233
>
> Website: http://baselogic.com
> Linked IN: http://linkedin.com/in/mickknutson
> Twitter: http://twitter.com/mickknutson
> Vacation Rental: http://tahoe.baselogic.com
> ---
>
>
>
> On Thu, Feb 26, 2009 at 10:02 AM, Mick Knutson <mickknutson@gmail.com>wrote:
>
>> Can anyone help me with this?
>>
>> I got it partially in settings.xml:
>>
>>             *<activation>
>>                   <property>
>>                       <name>!PRD</name>
>>                   </property>
>>             </activation>*
>>
>> But I actually have about 5 profiles that are NOT LOC (in my
>> settings.xml). How can I say:
>>
>> * **<name>!PRD && !QA && !INT</name>
>>
>> *
>> ---
>> Thank You…
>>
>> Mick Knutson, President
>>
>> BASE Logic, Inc.
>> Enterprise Architecture, Design, Mentoring & Agile Consulting
>> p. (866) BLiNC-411: (254-6241-1)
>> f. (415) 685-4233
>>
>> Website: http://baselogic.com
>> Linked IN: http://linkedin.com/in/mickknutson
>> Twitter: http://twitter.com/mickknutson
>> Vacation Rental: http://tahoe.baselogic.com
>> ---
>>
>>
>>
>> On Wed, Feb 25, 2009 at 10:41 AM, Mick Knutson <mickknutson@gmail.com>wrote:
>>
>>> I got it partially in settings.xml:
>>>
>>>             *<activation>
>>>                   <property>
>>>                       <name>!PRD</name>
>>>                   </property>
>>>             </activation>*
>>>
>>> But I actually have about 5 profiles that are NOT LOC (in my
>>> settings.xml). How can I say:
>>>
>>> * **<name>!PRD && !QA && !INT</name>*
>>>
>>>
>>>
>>> ---
>>> Thank You…
>>>
>>> Mick Knutson, President
>>>
>>> BASE Logic, Inc.
>>> Enterprise Architecture, Design, Mentoring & Agile Consulting
>>> p. (866) BLiNC-411: (254-6241-1)
>>> f. (415) 685-4233
>>>
>>> Website: http://baselogic.com
>>> Linked IN: http://linkedin.com/in/mickknutson
>>> Twitter: http://twitter.com/mickknutson
>>> Vacation Rental: http://tahoe.baselogic.com
>>> ---
>>>
>>>
>>>
>>> On Wed, Feb 25, 2009 at 10:34 AM, Mick Knutson <mickknutson@gmail.com>wrote:
>>>
>>>> How do I set the activation in the <profile> for that?
>>>>
>>>> ---
>>>> Thank You…
>>>>
>>>> Mick Knutson, President
>>>>
>>>> BASE Logic, Inc.
>>>> Enterprise Architecture, Design, Mentoring & Agile Consulting
>>>> p. (866) BLiNC-411: (254-6241-1)
>>>> f. (415) 685-4233
>>>>
>>>> Website: http://baselogic.com
>>>> Linked IN: http://linkedin.com/in/mickknutson
>>>> Twitter: http://twitter.com/mickknutson
>>>> Vacation Rental: http://tahoe.baselogic.com
>>>> ---
>>>>
>>>>
>>>>
>>>> On Wed, Feb 25, 2009 at 10:07 AM, Brett Porter <brett@apache.org>wrote:
>>>>
>>>>> This may be a bug - I'd need to test it to confirm.
>>>>>
>>>>> An alternative way to achieve this is to use two activations on system
>>>>> property, eg:
>>>>>
>>>>> !PRD and PRD
>>>>>
>>>>> and then use -DPRD instead.
>>>>>
>>>>> Please note that you might not get the results you are hoping for with
>>>>> this set up since the local repository retains information from previous
>>>>> builds.
>>>>>
>>>>> Cheers,
>>>>> Brett
>>>>>
>>>>>
>>>>> On 26/02/2009, at 1:56 AM, Mick Knutson wrote:
>>>>>
>>>>>  I want to, by default, use a dev REPO in my settings.xml, or an LOC
>>>>>> profile
>>>>>> that has <activeByDefault>true
>>>>>>
>>>>>> Then if I choose to build with a specific PRD profile (-PPRD), then
I
>>>>>> want
>>>>>> to use a PRD REPO instead of the DEV repo.
>>>>>>
>>>>>> In my pom, by default I have:
>>>>>>
>>>>>> *            <repositories>
>>>>>>               <repository>
>>>>>>                   <id>mvnprd</id>
>>>>>>                   <url>http://somehost:8080/archiva/repository/mvn-
>>>>>> prd
>>>>>> </url>
>>>>>>               </repository>
>>>>>>           </repositories>
>>>>>>           <pluginRepositories>
>>>>>>               <pluginRepository>
>>>>>>                   <id>**mvnprd**</id>
>>>>>>                   <url>http://somehost:8080/archiva/repository/mvn-
>>>>>> prd
>>>>>> </url>
>>>>>>               </pluginRepository>
>>>>>>           </pluginRepositories>
>>>>>> *
>>>>>>
>>>>>> I have this in my settings.xml:
>>>>>>
>>>>>>      * <profile>
>>>>>>           <id>default</id>
>>>>>>           <activation>
>>>>>>                 <activeByDefault>true</activeByDefault>
>>>>>>           </activation>
>>>>>>           <properties>
>>>>>>               <env>LOC</env>
>>>>>>           </properties>
>>>>>>
>>>>>>           <repositories>
>>>>>>               <repository>
>>>>>>                   <id>mvndev</id>
>>>>>>                   <url>http://somehost:8080/archiva/repository/mvn-
>>>>>> dev
>>>>>> </url>
>>>>>>               </repository>
>>>>>>           </repositories>
>>>>>>           <pluginRepositories>
>>>>>>               <pluginRepository>
>>>>>>                   <id>**mvnprd**</id>
>>>>>>                   <url>http://somehost:8080/archiva/repository/mvn-
>>>>>> prd
>>>>>> </url>
>>>>>>               </pluginRepository>
>>>>>>           </pluginRepositories>
>>>>>>       </profile>
>>>>>>   </profiles>*
>>>>>>
>>>>>> By default, I get the *mvn-dev* activated.
>>>>>>
>>>>>> But I can NOT seem to get the default profile NOT active if I use
a
>>>>>> different profile on the command line like "*mvn -PPRD package*".
It
>>>>>> still
>>>>>> used the default profile, thus the dev REPO.
>>>>>>
>>>>>> ---
>>>>>> Thank You…
>>>>>>
>>>>>> Mick Knutson, President
>>>>>>
>>>>>> BASE Logic, Inc.
>>>>>> Enterprise Architecture, Design, Mentoring & Agile Consulting
>>>>>> p. (866) BLiNC-411: (254-6241-1)
>>>>>> f. (415) 685-4233
>>>>>>
>>>>>> Website: http://baselogic.com
>>>>>> Linked IN: http://linkedin.com/in/mickknutson
>>>>>> Twitter: http://twitter.com/mickknutson
>>>>>> Vacation Rental: http://tahoe.baselogic.com
>>>>>> ---
>>>>>>
>>>>>
>>>>> --
>>>>> Brett Porter
>>>>> brett@apache.org
>>>>> http://blogs.exist.com/bporter/
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>>>>> For additional commands, e-mail: users-help@maven.apache.org
>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message