maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Beransky" <dmitry.ma...@gmail.com>
Subject Re: maven 2.0.9+ and windows absolute paths
Date Wed, 17 Dec 2008 23:00:55 GMT
Another datapoint:

I've taken out the ant plugin where the problem was showing up before,
so now the Cargo plugin is failing with the same error.  Here's my
Cargo configuration:

                <configuration>
                    <container>
                        <containerId>tomcat5x</containerId>
                        <type>remote</type>
                    </container>

                    <configuration>
                        <type>runtime</type>
                        <properties>
                            <cargo.tomcat.manager.url>
                                ${appserver.home}:8100/manager
                            </cargo.tomcat.manager.url>
                            <cargo.remote.username>csa</cargo.remote.username>
                            <cargo.remote.password>checkit
                            </cargo.remote.password>
                        </properties>
                    </configuration>

                    <deployer>
                        <type>remote</type>
                        <deployables>
                            <deployable>
                                <groupId>com.csatp.website</groupId>
                                <artifactId>csa</artifactId>
                                <location>
                                    ${project.build.directory}/${warName}.war
                                </location>
                                <type>war</type>
                            </deployable>
                        </deployables>
                    </deployer>
                </configuration>
            </plugin>


Just like the ant plugin before, Cargo configuration uses
${project.build.directory} variable that comes through with an
incorrectly resolved Windows path.


Dmitry
On Wed, Dec 17, 2008 at 10:50 AM, Dmitry Beransky
<dmitry.maven@gmail.com> wrote:
> On Tue, Dec 16, 2008 at 3:34 PM, Jörg Schaible <joerg.schaible@gmx.de> wrote:
>> Dmitry Beransky wrote:
>>
>>> Hi,
>>>
>>> It seems that Maven 2.0.9 has introduced a bug where Windows absolute
>>> paths aren't being properly resolved.
>>
>> [snip]
>>
>> Are you running Maven under Cygwin?
>
> Nope, pure unadulterated Windows.
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message