maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Fritz <sfritz.nos...@gmx.at>
Subject Dependency range resolution resolves to SNAPSHOTS!?
Date Wed, 08 Oct 2008 11:51:12 GMT
Hi all,

We recently (during the last weeks) ran into a situation where version 
ranges (e.g. [1.0,) ) where resolved to SNAPSHOT  versions as well.
My understanding was always that if I specify a non-snapshot version in 
a range that only released version will be resolved.

Is my understanding incorrect or is there a bug in dependency resolution?

I'm using 2.0.9

Thanks
Stefan


PS: Sorry if this has already discussed during the last weeks but 
couldn't find it in the archives

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message