maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Jakbot" <ben.jak...@gmail.com>
Subject starting with maven
Date Thu, 21 Aug 2008 22:46:44 GMT
hi
I try to start with maven and I'm sinking in tons of documentation.
Docs are a good thing, but I somehow miss the very obvious.

Right now I'm going through a the nice manual calling "Better Builds
with Maven". Basically I ran the following commands:

$mvn archetype:create -DgroupId=com.mycompany.app \
-DartifactId=my-app
$ cd my-app
$ mvn compile
$ mvn test
$ mvn test-compile
$ mvn package
$ mvn install

which magically generated my a project structure a hello world kind of
class and a test class for it. Then it compiled all the classes so
that I now have

$ ls target/
classes			maven-archiver		my-app-1.0-SNAPSHOT.jar	surefire-reports	test-classes

So my super simple task is complete this little roundtrip by running
the app "my-app-1.0-SNAPSHOT.jar". And the question is how can I run
it? Now I get the following error:

$ java target/my-app-1.0-SNAPSHOT.jar
Exception in thread "main" java.lang.NoClassDefFoundError:
target/my-app-1/0-SNAPSHOT/jar

I hoped not to have to mess around with classpathes. Could somebody
help me with this?

thanks in advance
ben

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message