maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene Kuleshov ...@md.pp.ru>
Subject Re: unpack-dependencies problem
Date Fri, 08 Aug 2008 15:44:43 GMT


  If you are using m2eclipse, you may want to try to install Maven 2.0.9 and
set Maven runtime in Eclipse to use external Maven pointing to 2.0.9
installation.

  regards,
  Eugene


anoweb wrote:
> 
> If I run this from eclipse (i.e. Run As -> Maven test) I get the following
> output:
> 
> Maven encountered an error while looking up the following Mojo:
> Group-Id: org.apache.maven.plugins
> Artifact-Id: maven-dependency-plugin
> Version: 2.0
> Mojo: unpack-dependencies
> brought in via: POM
> 
> Referenced from project:
> Group-Id: com.acme
> Artifact-Id: web
> Version: 1.0
> From file: C:\dev\web\pom.xml
> Reason: Unable to lookup component 'org.apache.maven.plugin.Mojo', it
> could not be created.
>       role: org.apache.maven.plugin.Mojo
>   roleHint:
> org.apache.maven.plugins:maven-dependency-plugin:2.0:unpack-dependencies
> classRealm:
> /plugins/org.apache.maven.plugins:maven-dependency-plugin:2.0@48/thread:main
> 
> Root cause: org.codehaus.plexus.archiver.ArchiverException
> 
-- 
View this message in context: http://www.nabble.com/unpack-dependencies-problem-tp18891876p18894332.html
Sent from the Maven - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message