maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: how to upgrade the version of transitive dependency?!
Date Tue, 01 Jul 2008 13:02:48 GMT
Hi Oliver,

oliver.maven wrote:

> hi,all
> 
> my Maven libraries container found a dependency ,which is asm-1.5.3.jar,it
> is automatically added by other dependency transitivly.
> 
> but the version is to low caused a ClassNotFound exception at runtime,
> 
> i can not add a new asm dependency by using m2eclipse,because the asm
> dependency already exist.
> 
> how to remove or upgrade the version of asm dependency?! appreciate for
> any help!

Well, you have to understand, that this is *not* a Maven problem. ASM 1.x
and ASM 2.x is simply not compatible. If one lib uses ASM 2.x it will break
the lib that uses ASM 1.x and vice versa.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message