maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "EJ Ciramella" <ejcirame...@upromise.com>
Subject RE: Strange m2 2.0.9 behavior
Date Thu, 31 Jul 2008 14:27:29 GMT
Done - MNG-3692

-----Original Message-----
From: Brian E. Fox [mailto:brianf@reply.infinity.nu] 
Sent: Wednesday, July 30, 2008 8:36 PM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behavior

Definitely news to me. Please file a bug in the war project as it
shouldn't stomp on the regular resource processing. At least you can
define the war plugin version back to 2.0.2 and get working again.

-----Original Message-----
From: EJ Ciramella [mailto:ejciramella@upromise.com] 
Sent: Wednesday, July 30, 2008 2:26 PM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behavior

For what it's worth - this is a change between the 2.0.2 version of the
war plugin to the 2.1-alpha-1 version (which is included in the 2.0.9
superpom).

This isn't called out (clearly) anywhere that I could find.

-----Original Message-----
From: EJ Ciramella [mailto:ejciramella@upromise.com] 
Sent: Wednesday, July 30, 2008 1:51 PM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behavior

Ok, I can reproduce this regularly.

We have a version.html file that has a ${label} token inside (as listed
below).  When I run with maven 2.0.9, using "mvn install", I can see
that version.html is copied into the target location twice, once via
process-resources (and it's expanded at this point) and then a second
time when the war plugin says:

[INFO] Assembling webapp[pdtApp] in
[E:\work\up-svcs\lty\rel\LTY-R66.0\programData\pdt-web\target\pdtApp-66.
0-SNAPSHOT]
[INFO] Processing war project        <-------------------------
[INFO] Webapp assembled in[2530 msecs]

This is a change since mvn 2.0.5.

I've NOT defined a war plugin, I'm only telling maven that the
<packaging> is war.  Is it looking at all the defined <resources> and
copying them over?





-----Original Message-----
From: EJ Ciramella [mailto:ejciramella@upromise.com] 
Sent: Wednesday, July 30, 2008 1:13 PM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behavior

Additionally, when did maven start expanding ${} to something like


MavenProject: lty:pdtApp:66.0-SNAPSHOT @
E:\work\up-svcs\lty\rel\LTY-R66.0\programData\pdt-web\pom.xml



-----Original Message-----
From: EJ Ciramella [mailto:ejciramella@upromise.com] 
Sent: Wednesday, July 30, 2008 11:33 AM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behavior

After some more research, here's what I've found.

When I run mvn install -Dfoo=bar, I can see version.html get copied
twice to:

project\webmodule\target\webmodule-X.X-SNAPSHOT

I ran with -X -e, but only see ONE copy step happen.  Basically, when
the war is generated, it copies over the file a second time but
unprocessed.

Is this a fundamental change between maven 2.0.5 and 2.0.9?

-----Original Message-----
From: EJ Ciramella [mailto:ejciramella@upromise.com] 
Sent: Tuesday, July 29, 2008 3:31 PM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behavior

I'm having a really hard time reproducing this outside of cruisecontrol.

Basically, we have this relationship:

Parent2 -> parent1 -> child

It's the "child" project who's process-resources step copies the
version.html from source to target replacing the ${label} within.

I've been able to reproduce this once building from the top most level,
but it takes 20 - 25 minutes for each build.  I trimmed away all the
other modules, and it properly replaces the ${label}.

I guess I was wondering if anyone else has seen anything like this at
all (with 2.0.9).

-----Original Message-----
From: Brian E. Fox [mailto:brianf@reply.infinity.nu] 
Sent: Tuesday, July 29, 2008 3:18 PM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behaviour

Can you get us a sample project to work on?

-----Original Message-----
From: EJ Ciramella [mailto:ejciramella@upromise.com] 
Sent: Tuesday, July 29, 2008 10:27 AM
To: Maven Users List
Subject: RE: Strange m2 2.0.9 behaviour

Is no one else replacing tokens with some values on the commandline?

Again - this worked great with 2.0.5 but stopped working in 2.0.9.

-----Original Message-----
From: EJ Ciramella [mailto:ejciramella@upromise.com] 
Sent: Monday, July 28, 2008 4:52 PM
To: users@maven.apache.org
Subject: Strange m2 2.0.9 behaviour

I'm seeing an issue with 2.0.9 I think.  Between the 21st and the 22nd,
the only change in the build environment was upgrading from 2.0.5 to
2.0.9.  

 

We're running cruise control and we are injecting the ${label} value
into some of our files during the build.  On the 22nd, this stopped
working leaving behind ${label} in the files that used to be processed
by the process-resources phase.

 

Is this a known issue or anything?  Anyone else seeing this?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message