maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian E. Fox" <bri...@reply.infinity.nu>
Subject RE: Can't run ant task in maven 2.0.9
Date Sun, 04 May 2008 14:14:27 GMT
Can you try to isolate this to the Ant task or Maven update? Ie don't
update them both at the same time and see which one actually causes the
breakage.

-----Original Message-----
From: Matthew Milliss [mailto:matt.milliss@gmail.com] 
Sent: Sunday, May 04, 2008 5:14 AM
To: users@maven.apache.org
Subject: Can't run ant task in maven 2.0.9

I've just installed maven 2.0.9 and added the 2.0.9 Maven tasks for ant 
into my ant install lib directory (ant 1.7) and now when I run my antrun

plugin it fails with the message:

Embedded error: The following error occurred while executing this line:
/home/development/workspace/backoffice/run-fit.xml:5: Could not create 
task or type of type: antlib:org.apache.maven.artifact.ant:dependencies.

I didn't have this issue with maven 2.0.7 or 2.0.8 with either ant 1.6.5

or 1.7. Has anybody experienced this issue and know what the problem is?

here is the antrun config in my pom:
           <plugin>
               <groupId>org.apache.maven.plugins</groupId>
               <artifactId>maven-antrun-plugin</artifactId>
               <executions>
                   <execution>
                       <id>Tests Run by Ant</id>
                          <phase>test</phase>
                          <goals>
                              <goal>run</goal>
                          </goals>
                       <configuration>
                           <tasks>
                               <ant antfile="${basedir}/run-fit.xml" 
dir="${basedir}" inheritRefs="true" />
                           </tasks>
                       </configuration>
                   </execution>
               </executions>
           </plugin>

and the ant build file:

<?xml version="1.0"?>
<project name="run-fit" default="run-tests" 
xmlns:artifact="antlib:org.apache.maven.artifact.ant">

   <target name="setup">
       <artifact:dependencies filesetId="aspectjweaver.fileset">
           <dependency groupId="aspectj" artifactId="aspectjweaver" 
version="1.5.3" />
       </artifact:dependencies>
   </target>

   <target name="run-tests" depends="setup">
       <echo message="I don't work" />
   </target>
</project>   

os
fedora core 6  version 2.6.22.14-72.fc6

java version "1.6.0_04"
Java(TM) SE Runtime Environment (build 1.6.0_04-b12)
Java HotSpot(TM) Client VM (build 10.0-b19, mixed mode, sharing)

Cheers
Matt



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message