maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian E. Fox" <bri...@reply.infinity.nu>
Subject RE: maven-war-plugin:2.0.2 confuses relative path when run in the reactor
Date Fri, 18 Apr 2008 17:35:22 GMT
Can you attach the entire build log and your parent and dependent poms?

-----Original Message-----
From: Harper, Brad [mailto:brad.harper@epsiia.com] 
Sent: Friday, April 18, 2008 12:25 PM
To: Maven Users List
Subject: RE: maven-war-plugin:2.0.2 confuses relative path when run in
the reactor

No good. I moved the <plugin> element for maven-war-plugin in the parent
pom from the

   <build>
     <plugins>

into a new

   <build>
     <pluginManagement>
       <plugins>

element. And then added

   <plugin>
     <groupId>org.apache.maven.plugins</groupId>
     <artifactId>maven-war-plugin</artifactId>
   </plugin>

under the [already existing] <build> element in the dependent pom file.

I'm seeing the same error.

Brad

> -----Original Message-----
> From: Brian E. Fox [mailto:brianf@reply.infinity.nu] 
> Sent: Friday, April 18, 2008 9:19 AM
> To: Maven Users List
> Subject: RE: maven-war-plugin:2.0.2 confuses relative path 
> when run in the reactor
> 
> It looks like the plugin is running in your parent, which is 
> probably not what you wanted. You want this to be inherited 
> but not run, so put it in the pluginManagment section instead.
> 
> -----Original Message-----
> From: Harper, Brad [mailto:brad.harper@epsiia.com]
> Sent: Thursday, April 17, 2008 11:36 PM
> To: Maven Users List
> Subject: maven-war-plugin:2.0.2 confuses relative path when 
> run in the reactor
> 
> I'm seeing a problem that appears to be nearly identical to 
> one posted here in the recent past. See
>    
>    http://www.mail-archive.com/users@maven.apache.org/msg77272.html
> 
> and the subsequent thread. The issue didn't seem to be 
> obviously resolved at that time.
> 
> The command line 'mvn install' works when run for a [war] 
> project individually, but fails for that same project when 
> 'mvn install' is run from it's parent.
> 
> In my case, the maven-war-plugin is configured [in the parent 
> project's pom] thusly
> 
>    <plugin>
>      <inherited>true</inherited>
>      <groupId>org.apache.maven.plugins</groupId>
>      <artifactId>maven-war-plugin</artifactId>
>      <version>2.0.2</version>
>      <configuration>
>        <webResources>
>          <resource>
> 		<filtering>true</filtering>
> 		<directory>src/main/webapp/WEB-INF</directory>
> 		<targetPath>WEB-INF</targetPath>
> 		<includes>
> 		  <include>**/web.xml</include>
> 		</includes>
>           </resource>
> 	  </webResources>
> 	</configuration>
>     </plugin>
> 
> The failure looks like
> 
> <<snip>>
> [DEBUG] Configuring mojo
> 'org.apache.maven.plugins:maven-war-plugin:2.0.2:war' -->
> [DEBUG]   (f) archiveClasses = false
> [DEBUG]   (s) classesDirectory = 
> P:\eclipse-workspace\ev\target\classes
> [DEBUG]   (f) filters =
> [P:\eclipse-workspace\ev\target\build.timestamp.properties]
> [DEBUG]   (f) outputDirectory = P:\eclipse-workspace\ev\target
> [DEBUG]   (f) primaryArtifact = true
> [DEBUG]   (s) project = MavenProject:
> com.epsiia.dxweb:ev:2.4.16-SNAPSHOT @ P:\eclipse-workspace\ev\pom.xml
> [DEBUG]   (f) warName = ev-2.4.16-SNAPSHOT
> [DEBUG]   (s) warSourceDirectory =
> P:\eclipse-workspace\ev\src\main\webapp
> [DEBUG]   (s) filtering = true
> [DEBUG]   (s) directory = src/main/webapp/WEB-INF
> [DEBUG]   (s) targetPath = WEB-INF
> [DEBUG]   (s) includes = [**/web.xml]
> [DEBUG]   (f) webResources = [Lorg.apache.maven.model.Resource;@9d267d
> [DEBUG]   (s) webappDirectory =
> P:\eclipse-workspace\ev\target\ev-2.4.16-SNAPSHOT
> [DEBUG]   (f) workDirectory = P:\eclipse-workspace\ev\target\war\work
> [DEBUG] -- end configuration --
> [INFO] [war:war]
> [INFO] Exploding webapp...
> [INFO] Assembling webapp ev in
> P:\eclipse-workspace\ev\target\ev-2.4.16-SNAPSHOT
> [INFO] Copy webapp webResources to
> P:\eclipse-workspace\ev\target\ev-2.4.16-SNAPSHOT
> [INFO]
> --------------------------------------------------------------
> ----------
> [ERROR] FATAL ERROR
> [INFO]
> --------------------------------------------------------------
> ----------
> [INFO] basedir src\main\webapp\WEB-INF does not exist [INFO]
> --------------------------------------------------------------
> ----------
> [DEBUG] Trace
> java.lang.IllegalStateException: basedir 
> src\main\webapp\WEB-INF does not exist
> 	at
> org.codehaus.plexus.util.DirectoryScanner.scan(DirectoryScanne
> r.java:542
> )
> 	at
> org.apache.maven.plugin.war.AbstractWarMojo.getWarFiles(Abstra
> ctWarMojo.
> java:824)
> <<snip>>
> 
> Thoughts anyone? Thanks.
> 
> Brad
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message