maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Re: maven-jar-plugin question
Date Sun, 02 Mar 2008 02:54:25 GMT
On Sat, Mar 1, 2008 at 7:50 PM,  <robert.egan@aciworldwide.com> wrote:
> The following POM works as expected when run by itself (it uses
>  org.apache.maven.plugins:maven-jar-plugin:2.1:jar) but when run as part of
>  a multi-module build it uses
>  org.apache.maven.plugins:maven-jar-plugin:2.2:jar. Does anyone have any
>  suggestions as to why this happens and how I can resolve it?

Try putting the maven-jar-plugin declaration in the parent pom,
probably in <pluginManagement>.

I could be wrong, but I don't think you can use different versions of
the same plugin in the same build.

-- 
Wendy

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message