maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebastien ARBOGAST" <sebastien.arbog...@gmail.com>
Subject Re: Bug with maven-dependency-plugin?
Date Sun, 02 Mar 2008 17:05:31 GMT
I don't have any other explicit dependency on it in other modules.Is there a
way to know if another plugin uses it implicitly?

2008/3/2, Olivier Lamy <olamy@apache.org>:
>
> An other module use the plugin with the version 2.0-alpha-4 ?
>
> --
> Olivier
>
> 2008/3/2, Sebastien ARBOGAST <sebastien.arbogast@gmail.com>:
>
> > I have a problem using maven-dependency-plugin. One of my modules
> configures
> >  this plugin:
> >  <plugin>
> >                 <groupId>org.apache.maven.plugins</groupId>
> >                 <artifactId>maven-dependency-plugin</artifactId>
> >                 <version>2.0</version>
> >                 <executions>
> >                     <execution>
> >                         <id>copy-flex-resources</id>
> >                         <phase>compile</phase>
> >                         <goals>
> >                             <goal>copy-dependencies</goal>
> >                         </goals>
> >                         <configuration>
> >                             <outputDirectory>${project.build.directory
> >  }/flex-resources</outputDirectory>
> >                             <includeTypes>swf,swc</includeTypes>
> >                             <stripVersion>true</stripVersion>
> >                         </configuration>
> >                     </execution>
> >                 </executions>
> >             </plugin>
> >
> >  And I get the following error:
> >
> >  [INFO]
>
> >  ------------------------------------------------------------------------
> >  [ERROR] BUILD ERROR
> >  [INFO]
>
> >  ------------------------------------------------------------------------
> >  [INFO] Internal error in the plugin manager executing goal '
> >
> org.apache.maven.plugins:maven-dependency-plugin:2.0-alpha-4:copy-dependencies
> ':
> >  Unable to find the mojo '
> >
> org.apache.maven.plugins:maven-dependency-plugin:2.0-alpha-4:copy-dependencies
> '
> >  in the plugin 'org.apache.maven.plugins:maven-dependency-plugin'
> >  Component descriptor cannot be found in the component repository:
> >
> org.apache.maven.plugin.Mojoorg.apache.maven.plugins:maven-dependency-plugin:2.0-alpha-4:copy-dependencies
> >  .
> >
> >  What does 2.0-alpha-4 do here?
> >  Does anybody have an idea?
> >
> >
> >  --
> >  S├ębastien Arbogast
> >
> >  http://sebastien-arbogast.com
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>


-- 
S├ębastien Arbogast

http://sebastien-arbogast.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message