maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert.e...@aciworldwide.com
Subject Re: maven-jar-plugin question
Date Sun, 02 Mar 2008 03:05:57 GMT
"Wendy Smoak" <wsmoak@gmail.com> wrote on 03/01/2008 09:54:25 PM:

> On Sat, Mar 1, 2008 at 7:50 PM,  <robert.egan@aciworldwide.com> wrote:
> > The following POM works as expected when run by itself (it uses
> >  org.apache.maven.plugins:maven-jar-plugin:2.1:jar) but when run as 
part of
> >  a multi-module build it uses
> >  org.apache.maven.plugins:maven-jar-plugin:2.2:jar. Does anyone have 
any
> >  suggestions as to why this happens and how I can resolve it?
> 
> Try putting the maven-jar-plugin declaration in the parent pom,
> probably in <pluginManagement>.
> 
> I could be wrong, but I don't think you can use different versions of
> the same plugin in the same build.
> 

I suspect you're right, and it would make sense to cahce them. However, I 
can't use 2.1 exclusively either. So I'll probably bind something to add 
an empty file to the generate-resources phase, and another one to remove 
it in the verify phase.

Thanks for the rapid response, especially on a Saturday night!


Robert Egan
--
This email message and any attachments may contain confidential, 
proprietary or non-public information.  The information is intended solely 
for the designated recipient(s).  If an addressing or transmission error 
has misdirected this email, please notify the sender immediately and 
destroy this email.  Any review, dissemination, use or reliance upon this 
information by unintended recipients is prohibited.  Any opinions 
expressed in this email are those of the author personally.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message