maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wayne Fay" <wayne...@gmail.com>
Subject Re: Compile error, cannot find locally installed resource
Date Tue, 04 Mar 2008 21:08:18 GMT
Its not finding the pom file because it doesn't exist, so its running
out and trying to find one in remote repos. Re-run mvn install and
this time specify -DgeneratePom=true along with the other parameters.

Wayne

On 3/4/08, buzzterrier <terry.jeske@gmail.com> wrote:
>
> Hello,
>
> I am new to Maven2 and am trying to get one of our applications building
> with it. I want to build myApp, and we have a home grown CoreTools.jar that
> is a dependency. The path of least resistance seemed to be to add
> CoreTools.jar as as dependency and then install it into my local repository.
>
>                <dependency>
>                        <groupId>com.foo.core</groupId>
>                        <artifactId>CoreTools</artifactId>
>                        <version>1.0-SNAPSHOT</version>
>                        <scope>compile</scope>
>                </dependency>
>
> The Core jar is installed:
> C:\Documents and
> Settings\buzzterrier\.m2\repository\com\foo\core\CoreTools\1.0-SNAPSHOT\CoreTools-1.0-SNAPSHOT.jar
>
>
> However, when I run the compile goal, it cannot resolve the path to it.
>
> ----
> [DEBUG] CoreTools: using locally installed snapshot
> [DEBUG] Trying repository gwt-maven
> Downloading:
> http://gwt-maven.googlecode.com/svn/trunk/mavenrepo//com/foo/core/CoreTools/1.0-SNAPSHOT/CoreTools-1.0-SNAPSHOT.pom
> [DEBUG] Unable to get resource 'com.foo.core:CoreTools:pom:1.0-SNAPSHOT'
> from repository gwt-maven
> (http://gwt-maven.googlecode.com/svn/trunk/mavenrepo/)
> [DEBUG] Skipping disabled repository central
> [DEBUG] Artifact not found - using stub model: Unable to download the
> artifact from any repository
>
>  com.foo.core:CoreTools:pom:1.0-SNAPSHOT
>
> from the specified remote repositories:
>  central (http://repo1.maven.org/maven2),
>  gwt-maven (http://gwt-maven.googlecode.com/svn/trunk/mavenrepo/)
>
> [DEBUG] Using defaults for missing POM
> com.foo.core:CoreTools:pom:1.0-SNAPSHOT:compile
> [DEBUG]   com.foo.core:CoreTools:jar:1.0-SNAPSHOT:compile (selected for
> compile)
> ...
>
>   [ERROR] Errors in
> 'C:\gwt-apps\myApp\src\main\java\com\foo\ComposeAction.java'
>      [ERROR] Line 19:  The import com.foo.core.Action cannot be resolved
>      [ERROR] Line 26:  Action cannot be resolved to a type
> ----
>
> where com.foo.core.Action resides in CoreTools.jar
>
> If I add Action.java to myApp/src/main/java/com/foo/core then it compiles.
>
> And the classpath from the maven output appears to correctly see the
> CoreTools.jar.
>
> Any ideas? I am certain that I am not handling the CoreTools.jar in an
> elegant way, but for right now I was just looking to get myApp to compile,
> and refactor from there.
>
>
> --
> View this message in context: http://www.nabble.com/Compile-error%2C-cannot-find-locally-installed-resource-tp15836706s177p15836706.html
> Sent from the Maven - Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message