maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian E. Fox" <bri...@reply.infinity.nu>
Subject RE: Bug with maven-dependency-plugin?
Date Mon, 03 Mar 2008 00:15:57 GMT
Huh? The flex2 plugin depends on the dependency plugin? That's not right...plugins shouldn't
be used as dependencies of other plugins and now you can see why.....

You might wanna ping the flex2 author and have him/her fix that.

-----Original Message-----
From: Sebastien ARBOGAST [mailto:sebastien.arbogast@gmail.com] 
Sent: Sunday, March 02, 2008 12:48 PM
To: Maven Users List
Subject: Re: Bug with maven-dependency-plugin?

I finally found the plugin that is using 2.0-alpha-4 version of
maven-dependency-plugin. One of my modules is using maven-flex2-plugin from
net.israfil.mojo which depends explicitly on maven-dependency-plugin:
2.0-alpha-4So I fixed the problem by changing the version of the plugin
configuration to 2.0-alpha-4. Now it works great.

2008/3/2, Dennis Lundberg <dennisl@apache.org>:
>
> Perhaps there is something wrong with the meta data in your local
> repository. You could try removing the following directory and have
> Maven download the artifact again:
>
> ~/.m2/repository/org/apache/maven/plugins/maven-dependency-plugin/
>
>
> Sebastien ARBOGAST wrote:
> > I have a problem using maven-dependency-plugin. One of my modules
> configures
> > this plugin:
> > <plugin>
> >                 <groupId>org.apache.maven.plugins</groupId>
> >                 <artifactId>maven-dependency-plugin</artifactId>
> >                 <version>2.0</version>
> >                 <executions>
> >                     <execution>
> >                         <id>copy-flex-resources</id>
> >                         <phase>compile</phase>
> >                         <goals>
> >                             <goal>copy-dependencies</goal>
> >                         </goals>
> >                         <configuration>
> >                             <outputDirectory>${project.build.directory
> > }/flex-resources</outputDirectory>
> >                             <includeTypes>swf,swc</includeTypes>
> >                             <stripVersion>true</stripVersion>
> >                         </configuration>
> >                     </execution>
> >                 </executions>
> >             </plugin>
> >
> > And I get the following error:
> >
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] BUILD ERROR
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Internal error in the plugin manager executing goal '
> >
> org.apache.maven.plugins:maven-dependency-plugin:2.0-alpha-4:copy-dependencies
> ':
> > Unable to find the mojo '
> >
> org.apache.maven.plugins:maven-dependency-plugin:2.0-alpha-4:copy-dependencies
> '
> > in the plugin 'org.apache.maven.plugins:maven-dependency-plugin'
> > Component descriptor cannot be found in the component repository:
> >
> org.apache.maven.plugin.Mojoorg.apache.maven.plugins:maven-dependency-plugin:2.0-alpha-4:copy-dependencies
> > .
> >
> > What does 2.0-alpha-4 do here?
> > Does anybody have an idea?
> >
>
>
> --
>
> Dennis Lundberg
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>


-- 
S├ębastien Arbogast

http://sebastien-arbogast.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message