maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Krishnamurthi, Venkat " <venkat.krishnamur...@citi.com>
Subject RE: Maven ignores my archetype selection
Date Mon, 25 Feb 2008 20:51:24 GMT
 
That works. Thanks! However, maven does not pick up the URL's specified
under <repositories> or <pluginrepositories> in settings.xml.
 How do we address that issue?


-----Original Message-----
From: Wendy Smoak [mailto:wsmoak@gmail.com] 
Sent: Monday, February 25, 2008 3:29 PM
To: Maven Users List
Subject: Re: Maven ignores my archetype selection

On Mon, Feb 25, 2008 at 1:21 PM, Krishnamurthi, Venkat
<venkat.krishnamurthi@citi.com> wrote:

>  But the archetype I'm trying to use is in an inhouse remote
repository.
>  I have specified that in my settings.xml. However, Maven is still 
> unable  to pick that up from settings.xml.
>  I also tried -DarchetypeRepository=<URL to the remote repository>.

The 2.0-alpha-2 release was supposed to restore backwards compatibility,
and the parameter used to be -DremoteRepositories=... .
 Does that work?

Old docs:
http://maven.apache.org/plugins/maven-archetype-plugin-1.0-alpha-7/creat
e-mojo.html

--
Wendy

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message