maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Saxena, Sandeep" <sandeep.sax...@bankofamerica.com>
Subject OverConstrainedVersionException
Date Wed, 12 Dec 2007 05:50:49 GMT
Hi All,

I am using following dependency in one of my POMs:

+++++++++++++++++++++++++++++++++++
<dependency>
       <groupId>org.eclipse</groupId>
       <artifactId>swt</artifactId>
       <version>[3.3.0-v3346]</version>
</dependency>
+++++++++++++++++++++++++++++++++++

And getting the following exceptions:

++++++++++++++++++++++++++++++++++++
Caused by:
org.apache.maven.artifact.versioning.OverConstrainedVersionException:
Couldn't find a version in [3.1.1, 3.2.
0, 3.3.0-v3346, 3.2.1-v3235e] to match range [3.3.0, 4.0.0)
  org.eclipse: swt: jar: null
++++++++++++++++++++++++++++++++++++


Any clues on this and how can it be resolved?

Regards,
Sandeep.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message