maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Chang <thomas200...@yahoo.de>
Subject Problem by Using Mirrors for Repositories
Date Fri, 28 Dec 2007 08:05:39 GMT
Hi all,
   
  I set my "settings.xml" so it will download the dependencies not from the central (i.g.
http://repo1.maven.org/maven2) but from my repository on the server maschine.
   
  The setting in my "settings.xml" looks as follow. 
   
  Does someone know what's wrong?
   
  Regards
   
  Thomas
   
  ...
  <mirror>
  <id>MyMirrorId</id>
  <mirrorOf>*</mirrorOf>
  <name>Dependencies for DKV Projects</name>
  <url>file://sap-dev/CVSREPO/CvsMaven</url>
  </mirror>
  ...
   
  The connection to file://sap-dev/CVSREPO/CvsMaven is ok. But as I want to run maven such
as "mvn eclipse:eclipse" I got error as follow:
   
  Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.
  E:\Projekte\Test>mvn clean
[INFO] Scanning for projects...
[INFO] -------------------------------------------------------------------------
---
[INFO] Building Test
[INFO]    task-segment: [clean]
[INFO] -------------------------------------------------------------------------
---
[INFO] [clean:clean]
[INFO] Deleting directory E:\Projekte\Test\target
[INFO] Deleting directory E:\Projekte\Test\target\classes
[INFO] Deleting directory E:\Projekte\Test\target\test-classes
[INFO] Deleting directory E:\Projekte\Test\target\site
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: < 1 second
[INFO] Finished at: Fri Dec 28 08:46:32 CET 2007
[INFO] Final Memory: 1M/3M
[INFO] ------------------------------------------------------------------------
  E:\Projekte\Test>mvn eclipse:eclipse
[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'eclipse'.
[INFO] -------------------------------------------------------------------------
---
[INFO] Building Test
[INFO]    task-segment: [eclipse:eclipse]
[INFO] -------------------------------------------------------------------------
---
[INFO] Preparing eclipse:eclipse
[INFO] No goals needed for project - skipping
Downloading: file://sap-dev/CVSREPO/CvsMaven/junit/junit/3.8.1/junit-3.8.1.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/junit/junit/3.8.1/junit-3.8.1.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/classworlds/classworlds/1.1-alpha-2
/classworlds-1.1-alpha-2.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/classworlds/classworlds/1.1-alpha-2
/classworlds-1.1-alpha-2.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/jline/jline/0.9.1/jline-0.9.1.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/jline/jline/0.9.1/jline-0.9.1.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/biz/aQute/bndlib/0.0.145/bndlib-0.0
.145.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/biz/aQute/bndlib/0.0.145/bndlib-0.0
.145.pom
Downloading: file://sap-dev/CVSREPO/CvsMaven/biz/aQute/bndlib/0.0.145/bndlib-0.0
.145.jar
Downloading: file://sap-dev/CVSREPO/CvsMaven/biz/aQute/bndlib/0.0.145/bndlib-0.0
.145.jar
Downloading: file://sap-dev/CVSREPO/CvsMaven/jline/jline/0.9.1/jline-0.9.1.jar
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.
  Missing:
----------
1) biz.aQute:bndlib:jar:0.0.145
    Try downloading the file manually from the project website.
    Then, install it using the command:
      mvn install:install-file -DgroupId=biz.aQute -DartifactId=bndlib \
          -Dversion=0.0.145 -Dpackaging=jar -Dfile=/path/to/file
Alternatively, if you host your own repository you can deploy the file there:
    mvn deploy:deploy-file -DgroupId=biz.aQute -DartifactId=bndlib \
          -Dversion=0.0.145 -Dpackaging=jar -Dfile=/path/to/file \
           -Durl=[url] -DrepositoryId=[id]
    Path to dependency:
        1) org.apache.maven.plugins:maven-eclipse-plugin:maven-plugin:2.4
        2) biz.aQute:bndlib:jar:0.0.145
  2) jline:jline:jar:0.9.1
    Try downloading the file manually from the project website.
    Then, install it using the command:
      mvn install:install-file -DgroupId=jline -DartifactId=jline \
          -Dversion=0.9.1 -Dpackaging=jar -Dfile=/path/to/file
Alternatively, if you host your own repository you can deploy the file there:
    mvn deploy:deploy-file -DgroupId=jline -DartifactId=jline \
          -Dversion=0.9.1 -Dpackaging=jar -Dfile=/path/to/file \
           -Durl=[url] -DrepositoryId=[id]
    Path to dependency:
        1) org.apache.maven.plugins:maven-eclipse-plugin:maven-plugin:2.4
        2) org.codehaus.plexus:plexus-interactivity-jline:jar:1.0-alpha-5
        3) jline:jline:jar:0.9.1
  ----------
2 required artifacts are missing.
  for artifact:
  org.apache.maven.plugins:maven-eclipse-plugin:maven-plugin:2.4
  from the specified remote repositories:
  central (http://repo1.maven.org/maven2),
  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository)
  
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1 second
[INFO] Finished at: Fri Dec 28 08:46:39 CET 2007
[INFO] Final Memory: 3M/6M
[INFO] ------------------------------------------------------------------------
  E:\Projekte\Test>
   
   

       
---------------------------------
Ihr erstes Baby? Holen Sie sich Tipps von anderen Eltern.
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message