maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Morgan <drklu...@cox.net>
Subject Re: Is there a way to restrict the version of maven used?
Date Thu, 01 Nov 2007 09:13:49 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jim Sellers wrote:
> Hi all.
> 
> I know that there is a way to express a version range for a plugin, but is
> there a way to do that with a pom?
> 
> So that if someone checks out the source and it's known to work with maven
> 2.0.7 and they are using 2.0.4, can it stop right away and say that they
> need to upgrade?

I believe you are looking for the prerequisites tag.
<prerequisites>2.0.7</prerequisites>

> 
> Thanks for your time,
> Jim
> 

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iD8DBQFHKZjNxyxe5L6mr7IRAhZQAJ9P01Ff+dmqi+yTMmwnYUMTEsD4IwCgh/rQ
K5vLw209Wfgag/kNJu1vbw8=
=bSd5
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message