maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Borut BolĨina" <borut.bolc...@gmail.com>
Subject Error doploying 3rd party jar
Date Thu, 11 Oct 2007 13:55:52 GMT
My sources deploy just fine on the company dav repo, but I am having
difficulties deploying 3rd party jars.

mvn deploy:deploy-file -DgroupId=de.nava -DartifactId=informa -Dversion=
0.6.5 -Dpackaging=jar
-Dfile=informa.jar-DrepositoryId=mycompany-maven-repository -Durl=dav:
https://maven.mycompany.com

[INFO] [deploy:deploy-file]
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error deploying artifact: Unsupported Protocol: 'dav': Cannot find
wagon which supports the requested protocol: dav

Component descriptor cannot be found in the component repository:
org.apache.maven.wagon.Wagondav.

.m2/settings.xml

<?xml version="1.0" encoding="UTF-8"?>
<settings>
    <servers>
        <server>
            <id>mycompany-maven-repository</id>
            <username>myusername</username>
        </server>
    </servers>
</settings>

I executed the above command in with -U also and with empty local repo,
using proxy repo (maven-proxy) and without it with no success. I can put
files with BitKinex (webdav windows gui client) on the filesystem with the
same user name. I do have server certificate (https) imported into JDK
(keytool cacerts).

Any suggestion?

Regards,
Borut


P.S. I know I was able to deploy 3rd party jars in the same repo a while
ago...

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message