maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angel Sotirov <an...@devbg.piranko.com>
Subject Re: Maven Performance
Date Thu, 04 Oct 2007 01:09:00 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Greg Morgan wrote:
> Angel Sotirov wrote:
> > Hi
>
> >     We are using Maven2 - Archiva and last two weeks we have serious
> > performance problems. Maven is taking more than 15min to build
> > relatively small project. Apparently the problem is getting updates
> > from one of the 4 Archiva repositories.
> >     What could the cause of this? Could it be a Maven's local
> > configuration problem ?
>
>
> If a build has to plow through these messages for every file access, I'd
> think that would slow things down. Can you zero in on these error
> messages?  Are there server messages in logs that can help you?
>
here is the message I'm getting from Archiva :
jvm 1    | 1978174 [SocketListener0-3] WARN
org.apache.maven.archiva.proxy.RepositoryProxyConnectors:default -
Resource does not exist: Unable to locate resource in repository
jvm 1    | 1978602 [SocketListener0-3] WARN
org.apache.maven.archiva.proxy.RepositoryProxyConnectors:default -
Resource does not exist: Unable to locate resource in repository
jvm 1    | 1978905 [SocketListener0-3] WARN
org.apache.maven.archiva.proxy.RepositoryProxyConnectors:default -
Resource does not exist: Unable to locate resource in repository
jvm 1    | 1979346 [SocketListener0-3] WARN
org.apache.maven.archiva.proxy.RepositoryProxyConnectors:default -
Resource does not exist: Unable to locate resource in repository
jvm 1    | 1980412 [SocketListener0-3] WARN
org.apache.maven.archiva.proxy.RepositoryProxyConnectors:default -
Resource does not exist: Unable to locate resource in repository

this message repeats literally thousands of times. The info presented
is not enough and i can't find what is causing it.
Maven in the mean time waits:

[INFO] snapshot org.ajax4jsf:ajax4jsf:1.1.2-SNAPSHOT: checking for
updates from snapshots
[WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for
org/ajax4jsf/ajax4jsf/1.1.2-SNAPSHOT/maven-metadata.xml - IGNORING

- -> More than 2-3 min between updates and i'm sure it is not a network
issue.

[INFO] snapshot org.ajax4jsf:master:1.1.2-SNAPSHOT: checking for
updates from snapshots
[WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for
org/ajax4jsf/master/1.1.2-SNAPSHOT/maven-metadata.xml - IGNORING


> Resource does not exist: if the file is on a network share, has it been
> moved?  Has the share of nfs file system been unmounted?  A reboot of a
> server with a non-permanent mount could cause this.  Did someone do
> maintenance on your server without telling you?  Example, Gee I need to
> find some disc space.  Angel hasn't updated this file in 3 months.  I'll
> delete it to make room for my stuff.
I've set everything local on the server there are no shares or remote
resources.
all repositories resides on separate hard drive and there in more than
300GB space

/dev/hde2            350G    32G    319G  19% /workspace

$ls -l  /workspace/mavenrepos/
total 6
- -rwxrwxrwx  1 archiva developers  335 Sep 26 07:04 checksum.sh
drwxrwx--- 64 archiva developers 1776 Sep 27 14:14 internal
drwxrwx--- 34 archiva developers  936 Sep 21 15:24 plugins
drwxrwx---  7 archiva developers  184 Sep 27 12:23 releases
drwxrwx---  4 archiva developers   96 Sep 20 11:00 snapshots
>
> If your server is running smart disk utilities, is your hard drive
> causing problems?  A bad disk may cause these messages i.e. a disk may
> be ready to fail. A missing file or directory, can be your first hint of
> a coming failure http://www.linuxjournal.com/article/6983 .
>
Nope the server is in perfect condition. The load is 0.07 while
Archiva is running so there are plenty  of  resources  available to
Archiva, i've even tried changing the nice so that is can be almost
real time scheduled
> Did you install a new version of Maven, Jdk, archiva, plugin, etc?
>
Yes everything is up to date
    dev-java/maven-bin-2.0.7
    dev-java/sun-jdk-1.5.0.13
i've build Archiva manually there was some null pointer exception that
needed to be fixed.
    archiva-1.0-beta3

> >     BTW. Archiva is generating tons of WARN messages: Resource does
> > not exist: Unable to locate resource in repository?!? and File does
> > not exist exception.
>
> You'd need to proved this kind of information too.  At this point I can
> only provide wild guesses to get you started on a solution.  It would be
> interesting to hear what you found in a follow-up email.
>
My guess would be that this is some kind of proxy-repository
misconfiguration or mistake, but the documentation is exiguous and
cant' find anything on the net. I've also installed couple previous
versions of archiva with no success.
i still can't find neat solution to the CHECKSUM PROBLEM

[WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for
org/richfaces/suggestionbox/3.0.2-SNAPSHOT/maven-metadata.xml - IGNORING
[INFO] snapshot org.richfaces:suggestionbox:3.0.2-SNAPSHOT: checking
for updates from snapshots

could this be the main reason for lag?

> Regards,
> Greg
>

Thanks in advance :)

Angel.
- ---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org



-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQFHBD0rhgSIDFxSFd0RAlfAAJ9AnmgcfoYRPh+Uo7Wp6VOSx1L3KgCgrUml
Jo4+Lz6m3njopGVQq2eA7HQ=
=2yya
-----END PGP SIGNATURE-----


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message