maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mailming <mailm...@gmail.com>
Subject Re: Install/Deploy an artifact with classifier
Date Wed, 31 Oct 2007 19:31:07 GMT

I revised the configuration, and turns out working perfect.
I can just do mvn deploy without "-d" any config string. my email is
mailming@gmail.com if any questions. 
			<plugin>
			 <artifactId>maven-deploy-plugin</artifactId>
			<executions> 
			<execution>         
			<id>deploy-delta-zip</id> 
			<phase>deploy</phase> 
			<goals> 
				<goal>deploy-file</goal> 
			</goals> 
			   <configuration> 
			<groupId>${parent.groupId}</groupId>
			<artifactId>deployment</artifactId>
			<file>target/${artifactId}-${version}-delta.zip</file>
			<version>${version}</version>
			<uniqueVersion>false</uniqueVersion>
			<url>file:///repository/deployment</url>
			<packaging>zip</packaging>
			<classifier>delta</classifier>
			</configuration>
			</execution> 
				<execution>         
				<id>deploy-alpha-zip</id> 
				<phase>deploy</phase> 
				<goals> 
					<goal>deploy-file</goal> 
				</goals> 
				   <configuration> 
				<groupId>${parent.groupId}</groupId>
				<artifactId>deployment</artifactId>
				<file>target/${artifactId}-${version}-alpha.zip</file>
				<version>${version}</version>
				<uniqueVersion>false</uniqueVersion>
				<url>file:///repository/deployment</url>
				<packaging>zip</packaging>
				<classifier>alpha</classifier>
				</configuration>
				</execution> 
				<execution>         
				<id>deploy-prod-zip</id> 
				<phase>deploy</phase> 
				<goals> 
					<goal>deploy-file</goal> 
				</goals> 
				<configuration> 
					<groupId>${parent.groupId}</groupId>
					<artifactId>deployment</artifactId>
					<file>target/${artifactId}-${version}-prod.zip</file>
					<version>${version}</version>
					<uniqueVersion>false</uniqueVersion>
					<url>file:///repository/deployment</url>
					<packaging>zip</packaging>
					<classifier>prod</classifier>
				</configuration>
				</execution> 
			</executions>
			</plugin>


Tommy Knowlton wrote:
> 
> I'm trying to produce a POM for building several different artifacts
> from the same sources.
> In the <profiles> section, I have accomplished
> 
> 1) configuring the build tools to do something different for each profile
> 2) activating the profiles
> 3) give the profile's artifact a unique name using classifier
> configuration in the maven-war-plugin
> 
> but what I haven't been able to do is to support the install/deploy of
> the profile's artifact.
> It seems install and deploy expect a "base" artifact that I'm not
> building (since each profile is building it's own "classified"
> artifact).
> 
> I'm thinking others must have solved this problem, but I haven't yet
> seen anything useful in Google.
> 
> Thanks,
> --
> Tommy
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Install-Deploy-an-artifact-with-classifier-tf3321017s177.html#a13517023
Sent from the Maven - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message