maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Rowlands" <ian.rowla...@bigfoot.com>
Subject Re: Why doesn't my index.html get generated when generating my site?
Date Wed, 02 May 2007 12:15:28 GMT
So, any reasons why the index.html is not being generated? It seems to
be a relatively common problem.

Thanks,

Ian



Ian Rowlands
Sun, 29 Apr 2007 06:21:13 -0700

I have been told that an index.html should be generated, and it is not.
This is an issue because it is a multi-module project, and links on the
"parent" project all link to the index.html of the sub-projects.  So
without the index.html nobody can navigate the site correctly.

Any reason why the index.html is not being generated?

Thanks,

Ian



Eric Redmond
Fri, 27 Apr 2007 23:46:50 -0700

I don't understand your problem - it looks like it is working... you
haven't
added any files and the default reports are generating. And?

Eric

On 4/27/07, Ian Rowlands <[EMAIL PROTECTED]> wrote:


        I'm using Maven 2.0.5.  My sites have no customisation (which I
won't do
        until I get this to work).  I am getting the following
generated:
        Apart from subdirectories, I get:
                checkstyle.html (plus checkstyle.rss)
                cpd.html and cpd.xml
                dependencies.html
                integration.html
                issue-tracking.html
                jdepend-report.html
                pmd.html and pmd.xml
                project-info.html
                project-reports.html
                surefire-report.html
        
        I'm using version 2.0-beta-5 of the web site plugin.
        
        Any suggestions on how to get this to work?
        
        Thanks,
        
        Ian
        




--
Eric Redmond
http://www.sonatype.com



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message