maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <Joerg.Schai...@Elsag-Solutions.com>
Subject RE: <type> to include test jar dependencies not working
Date Wed, 04 Apr 2007 09:37:26 GMT

Hi Raju,

use type "test-jar" and omit the classifier here.

- Jörg

raju wrote on Wednesday, April 04, 2007 11:08 AM:

> Hi,
> 
> I have to include 2 jars say xyz-1.0-SNAPSHOTS.jar and
> xyz-1.0-SNAPSHOTS-tests.jar as dependencies while building a war.
> As both are installed with the same groupid and artifact id in the
> local-repositorys as part of build that builds them,say:
>   <groupid>com.example<groupid> <artifactid>xyz</artifactid>
> 
> Now if i use the following as dependencies while building my
> war only the
> test jar gets included in web-inf/lib with the name
> xyz-1.0-SNAPSHOTS.jar and the orgininal non test jar
> 			xyz-1.0-SNAPSHOTS.jar gets ignored : <dependency>
> 			<groupId>com.example</groupId> <artifactId>xyz</artifactId>
> 			<version>1.0-SNAPSHOT</version>
> 			<scope>runtime</scope>
> 		</dependency>
> <dependency>
> 			<groupId>com.example</groupId>
> 			<artifactId>xyz</artifactId>
> 			<version>1.0-SNAPSHOT</version>
> 			<classifier>tests</classifier>
> 			<scope>runtime</scope>
> 		</dependency>
> 
> Regards
> Raju

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message