maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Wood <wo...@ucalgary.ca>
Subject Re: antlib - fails to grab snapshot dependencies?
Date Thu, 26 Apr 2007 23:02:34 GMT
Well apparently the solution is to revert back to 2.0beta3, add a  
whack of new dependency jars, specify the dependencies element twice,  
and you're good to go (thanks to Kevin for the hint).

http://jira.codehaus.org/browse/MANTTASKS-18?rc=1

Lots of interest in that bug.

One curious thing is that 2.0.4 will download new snapshots, but  
won't reference them in the fileset.

J

On 19-Apr-07, at 12:10 PM, Julian Wood wrote:

> I'm using Antlib for Maven 2.0.4  to get a reference to the  
> dependencies in my pom for use in some ant targets. It works fine  
> (though you have to fiddle with your pom to get rid of the NPE's),  
> but now it won't reference the snapshot dependencies. I've tried a  
> bunch of different useScope values, but none will ref these  
> snapshots (which are not only deployed but also installed and in  
> common use by other maven goals).
>
>         <artifact:dependencies pathId="dependency.classpath"  
> filesetId="compile.dependency.fileset" useScope="compile">
>             <pom refid="maven.project"/>
>         </artifact:dependencies>
>
> What do I need to do?
>
> Thanks,
>
> J

--
Julian Wood <woodj@ucalgary.ca>

Software Engineer
Teaching & Learning Centre
University of Calgary

http://tlc.ucalgary.ca



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message