maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rod Mclaughlin <Rod.Mclaugh...@omnimedix.org>
Subject Maven 2 can't find plugins
Date Tue, 13 Feb 2007 23:54:12 GMT
I have an even more basic issue. Whenever I have a plugin in a POM.xml 
file, and try to use it, eg.
*$ mvn xfire:wsdlgen *
Maven 2 says*
'Scanning for projects... Searching repository for plugin with prefix: 
'xfire'. org.apache.maven.plugins: checking for updates 
org.codehaus.mojo: checking for updates from central artifact 
org.apache.maven.plugins:maven-xfire-plugin: checking for updates from 
central
[ERROR] BUILD ERROR
The plugin 'org.apache.maven.plugins:maven-xfire-plugin' does not exist 
or no valid version could be found'*
This is true whatever the plugin. It's not a proxy issue: it can 
download ordinary jars from the repository, just not plugins. For 
example, here is a simple bit of a POM referring to xfire-maven-plugin:
    <build>
            <pluginManagement>
                <plugins>

                <plugin>
                    <groupId>org.codehaus.mojo</groupId>
                    <artifactId>xfire-maven-plugin</artifactId>
                        <executions>
                           <execution>
                              <phase>test-compile</phase>
                              <goals>
                                 <goal>wsdlgen</goal>
                              </goals>
                           </execution>
                        </executions>
                        <!-- this shows the default -->
                        <configuration>
                          
<outputDirectory>${project.build.directory}/generated-sources/xfire/wsdlgen</outputDirectory>
                          <configs>
                            
<wsdl>${basedir}/src/main/resources/META-INF/xfire/services.xml</wsdl>
                          </configs>
                        </configuration>

                </plugin>

            </plugins>
       </pluginManagement>
  </build>


Again, I've searched the web, the mailing lists etc.. Thanks for any 
advice...



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message