maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vidya Mahavadi <vidya.mahav...@rmb.co.za>
Subject jboss-maven-plugin
Date Wed, 31 Jan 2007 11:08:00 GMT
Hi,

I am trying to use jboss-maven-plugin(maven2) from codehaus for deployment 
in jboss 4.0. Here is my plugin configuration, can anyone please tell me 
what I am missing in here..

            <plugin>
                <groupId>org.codehaus.mojo</groupId>
                <artifactId>jboss-maven-plugin</artifactId>
                <configuration>
                    <jbossHome>c:/software/jboss-4.0.5.GA</jbossHome>
                    <server>default</server>
                    <hostName>localhost</hostName>
                    <port>8080</port>
                    <fileName>
 
${project.build.directory}\${project.build.finalName}.${project.packaging}
                    </fileName>
 
                </configuration>
            </plugin>

And here is the error trace.

[INFO] [jboss:deploy]
[INFO] Deploying 
C:\Vidya\WorkSpace\dealamendments\target\dealamendments-1.0-SNAPSHOT.jar 
to JBoss.
[INFO] 
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] 
------------------------------------------------------------------------
[INFO] Mojo error occurred: Server not defined in settings.xml: default


Thanks,
Vidya

This e-mail is subject to a disclaimer, available at
http://www.rmb.co.za/web/elements.nsf/online/disclaimer-communications.html


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message