maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukas Theussl <ltheu...@apache.org>
Subject Re: [M1] can't build M1 trunk because maven-model 3.0.2-20061008.232644 not found.
Date Mon, 06 Nov 2006 12:40:06 GMT

I have re-deployed the nsis snapshot so this should be fixed now. As for 
your second problem, I cannot reproduce it ... running 'maven' in the 
plugins root folder works for me. Arnaud, any idea?

Thanks for the feedback!
-Lukas


Davy Toch wrote:
> Hi,
> 
> The problem with maven-model-3.0.2-2006....jar not being found is
> solved.
> 
> However when running the following on the M1 'core' trunk:
> 
>  maven maven:build-install
> 
> I now get:
> 
>  ...
>  [copy] Copying 1 file to 
> C:\devtools\src\m1\trunk\core\target\installer\maven-1.1-RC1-SNAPSHOT\plugins 
> 
>  [echo] Downloading maven:maven-nsis-plugin version 2.1-SNAPSHOT
> plugin:download-artifact:
>  [echo] repo is 'http://repo1.maven.org/maven'
>  [echo] trying to download 
> http://repo1.maven.org/maven/maven/plugins/maven-nsis-plugin-2.1-SNAPSHOT.jar 
> 
>  [echo] repo is 'http://people.apache.org/repo/m1-snapshot-repository'
>  [echo] trying to download 
> http://people.apache.org/repo/m1-snapshot-repository/maven/plugins/maven-nsis-plugin-2.1-SNAPSHOT.jar

> 
> 
> BUILD FAILED
> File...... file:/C:/Documents and
>  Settings/dto/.maven/cache/maven-plugin-plugin-1.7/plugin.jelly
> Element... ant:fail
> Line...... 483
> Column.... 52
> Unable to find plug-in
> Total time   : 35 seconds
> Finished at  : 04 November 2006 12:00:24 CET
> Testsuite: org.apache.maven.artifact.PomRewriterTest
> Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0.751 sec
> 
> Apparently version 2.1-SNAPSHOT of the nsis plugin isn't available in
> the central repositories.
> 
> So I downloaded the latest M1 'plugins' trunk. This includes
> 2.1-SNAPSHOT of the nsis plugin. I rebuilt this with:
> 
>  cd nsis
>  maven plugin:repository-install
> 
> Afterwards I didn't have any problems anymore when building the M1 core.
> 
> 
> REMARK : when rebuilding *all* the plugins by running 'maven' in the root
> of the plugins folder, I get the following error during execution of the
> tests of maven-artifact-plugin:
> 
> ...
> 
> +----------------------------------------
> | Install Maven Artifact Plugin
> | Memory: 8M/13M
> +----------------------------------------
> 
> build:end:
> 
> build:start:
> 
> ...
> 
> BUILD FAILED
> File...... file:/C:/devtools/src/m1/trunk/plugins/maven.xml
> Element... maven:reactor
> Line...... 20
> Column.... 197
> Unable to obtain goal [plugin:plugin] -- file:/C:/Documents and
>  Settings/dto/.maven/cache/maven-test-plugin-1.8/plugin.jelly:152:49:
>  <junit> Test org.apache.maven.artifact.PomRewriterTest failed
> Total time   : 23 seconds
> Finished at  : 04 November 2006 12:04:08 CET
> 
> The actual error in the JUnit testcase is :
> 
> Testcase: 
> testPropertiesRewriting(org.apache.maven.artifact.PomRewriterTest):    
> Caused an ERROR
> Error getting the project as a string
> org.apache.maven.MavenException: Error getting the project as a string
>    at 
> org.apache.maven.artifact.PomRewriter.getRewrittenModel(PomRewriter.java:151) 
> 
>    at 
> org.apache.maven.artifact.PomRewriterTest.testPropertiesRewriting(PomRewriterTest.java:51)

> 
> --- Nested Exception ---
> java.lang.reflect.InvocationTargetException
>    at 
> org.apache.maven.artifact.PomRewriter.getRewrittenModel(PomRewriter.java:86) 
> 
>    at 
> org.apache.maven.artifact.PomRewriterTest.testPropertiesRewriting(PomRewriterTest.java:51)

> 
> Caused by: java.lang.NoClassDefFoundError: 
> org/apache/maven/project/io/xpp3/MavenXpp3Reader
>    at org.apache.maven.project.Project.<init>(Project.java:133)
>    at org.apache.maven.MavenUtils.getNonJellyProject(MavenUtils.java:193)
>    ... 21 more
> 
> It seems some classes were removed from maven-model-3.0.2 which are
> still needed in the maven-artifact-plugin.
> 
> Regards,
> Davy Toch
> 
> Arnaud HERITIER wrote:
> 
>> Hi Davy,
>>
>>   Sorry for this problem. It's due to the recent changes on apache 
>> infrastructure. We lost all snapshots between end of august and few 
>> days ago :-(
>>   I just uploaded it. Tell me if something else is missing.
>>   In parallel, I'll try to do a bootstrap with an empty repository.
>>
>> Thanks
>>
>> arnaud
>>
>> On 11/1/06, *Davy Toch* < Davy.Toch@belgacom.net 
>> <mailto:Davy.Toch@belgacom.net>> wrote:
>>
>>     Hi,
>>
>>     The root POM of the M1 trunk in SVN apparently has a dependency to a
>>     version of maven-model that can't be found in the central
>>     repositories:
>>
>>     maven-1/core/project.xml:
>>
>>       <dependency>
>>         <groupId>maven</groupId>
>>         <artifactId>maven-model</artifactId>
>>         <version>3.0.2-20061008.232644</version>
>>         ...
>>       </dependency>
>>
>>     I retrieved the M1 trunk from SVN with:
>>
>>       svn co http://svn.apache.org/repos/asf/maven/maven-1/trunks maven-1
>>
>>     My central repository settings in ~/build.properties:
>>
>>       maven.repo.remote=\
>>         http://repo1.maven.org/maven,\ <http://repo1.maven.org/maven,%5C>
>>         http://people.apache.org/repo/m1-snapshot-repository
>>
>>     I checked both repositories and the indicated version is indeed not
>>     available.
>>
>>     Regards,
>>     Davy Toch
>>
>>
>>
>>     ---------------------------------------------------------------------
>>     To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>>     <mailto:users-unsubscribe@maven.apache.org>
>>     For additional commands, e-mail: users-help@maven.apache.org
>>     <mailto:users-help@maven.apache.org>
>>
>>
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message