maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <Joerg.Schai...@Elsag-Solutions.com>
Subject RE: How to override jar-plugin dependencies to use a custom version of maven-archiver?
Date Tue, 05 Sep 2006 11:53:36 GMT
Hi Max,

Max Bowsher wrote on Tuesday, September 05, 2006 10:38 AM:

> Lakshman Srilakshmanan wrote:
>> Hi Max,
>> 
>> Page 58, in Better builds with Maven explains how to achieve this.
>> Essentially you have to do the following.
>> 
>> <dependencies>
>>     <dependency>
>>         <groupId>org.codehaus.plexus</groupId>
>>         <artifactId>plexus-container-default</artifactId>
>>         <version>1.0-alpha-9</version>
>>         <exclusions>
>>             <exclusion>
>>                 <groupId>org.codehaus.plexus</groupId>
>>                 <artifactId>plexus-utils</artifactId>            
>>         </exclusion> </exclusions>
>>     </dependency>
>>     <dependency>
>>         <groupId>org.codehaus.plexus</groupId>
>>         <artifactId>plexus-utils</artifactId>
>>         <version>1.1</version>
>>         <scope>runtime</scope>
>>     </dependency>
>> </dependencies>
> 
> 
> I had already tried that, but it didn't seem to translate from normal
> dependencies to plugin dependencies.
> 
> Do you know if it is possible to make it work for plugin
> dependencies? How? 

You can't - at least not those two. These jars are part of the core functionality (see "<maven
root>/core") and those will always take porecedence. So either you modify your local Maven
installation or you'll have to wait for the next Maven release.

- Jörg

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message