maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sharma, Jaikumar" <jaikumar.sha...@barco.com>
Subject RE: Is it possible to build Eclipse 3.1 plugins using M2 ?
Date Thu, 24 Aug 2006 09:05:46 GMT
Thanks Stephance. I was able to install the 2.3 SNAPSHOT plugin from the
repository, now I can play around to build the plugins.
Thanks for your help!
Regards.

-----Original Message-----
From: Stéphane Bouchet [mailto:stephane.bouchet@knowesia.fr] 
Sent: Thursday, August 24, 2006 1:27 PM
To: Maven Users List
Subject: Re: Is it possible to build Eclipse 3.1 plugins using M2 ?


It's on apache SNAPSHOT repo .

http://people.apache.org/maven-snapshot-repository/org/apache/maven/plugins/
maven-eclipse-plugin/2.3-SNAPSHOT/



add the following in your $HOME/.m2/settings.xml :

<pluginRepositories>
......

            <pluginRepository>
                <id>apache-snapshot</id>
                <name>Apache Snapshots repository</name>
                <url>
                    http://people.apache.org/maven-snapshot-repository
                </url>
                <snapshots>
                    <enabled>true</enabled>
                </snapshots>
                <releases>
                    <enabled>false</enabled>
                </releases>
            </pluginRepository>

</pluginRepositories>


Stéphane

Sharma, Jaikumar a écrit :
> Thanks Stephane. I am not able to locate this plugin version in M2 
> repo. Regards
>
> -----Original Message-----
> From: Stéphane Bouchet [mailto:stephane.bouchet@knowesia.fr]
> Sent: Wednesday, August 23, 2006 1:50 PM
> To: Maven Users List
> Subject: Re: Is it possible to build Eclipse 3.1 plugins using M2 ?
>
>
> There is also a thread about building eclipse RCP apps but i believe
> this is for eclipse 3.2 :
>
> http://www.nabble.com/Eclipse-bundle-howto-tf2065506.html#a5690799
>
> Stéphane.
>
> Valerio Schiavoni a écrit :
>   
>> after a quick search, i found it my self.
>>
>> adding these lines to your pom:
>> <plugin>
>>      <artifactId>maven-eclipse-plugin</artifactId>
>>              <version>2.3-SNAPSHOT</version>
>>                   <configuration>
>>                       <pde>true</pde>
>>                   </configuration>
>>  </plugin>
>>
>> you should be able at least to compile an eclipse plugin.
>>
>> On 8/23/06, Valerio Schiavoni <valerio.schiavoni@gmail.com> wrote:
>>     
>>>  improvements in the maven-eclipse-plugin
>>>
>>>       
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message