maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amshoff Christoph, Köln" <Christoph.Amsh...@fja.com>
Subject AW: [m2] Same output dir for maven and eclipse?
Date Thu, 24 Aug 2006 10:14:28 GMT
Well... I thought there could be problems when merging class files generated
by Maven with those generated by Eclipse. Not sure how Eclipse handels this
situation. 

But when Maven's Eclipse plugin (don't know that yet) is setting it up this
way, it's probably safe.

Thanx,
Christoph.

> -----Ursprüngliche Nachricht-----
> Von: Ralph Pöllath [mailto:lists@poellath.org] 
> Gesendet: Donnerstag, 24. August 2006 11:46
> An: Maven Users List
> Betreff: Re: [m2] Same output dir for maven and eclipse?
> 
> 
> On 24.08.2006, at 10:45, Amshoff Christoph, Köln wrote:
> > I'm setting up a project where team members could use 
> either Maven2 or
> > Eclipse to build the project. Normally, Maven will be used during  
> > CI/nightly
> > builds and Eclipse by developers.
> 
> Same here.
> 
> > The question is: where is the particular output of these builds  
> > going? Do
> > you recommend to use the same output folder for compiled 
> classes of  
> > both
> > tools, or what are the best practices in this case?
> 
> Is there any reason to separate the output folders? We use the maven  
> eclipse plugin [1] to generate our eclipse project files, which re- 
> uses maven's output directories for eclipse (at least by default).
> 
> Cheers,
> -Ralph.
> 
> [1] http://maven.apache.org/plugins/maven-eclipse-plugin/overview.html
> 
> 
> > If not using the same folder, I wish to put both output folder  
> > under target.
> > So I would have to configure maven to use target/maven/classes and
> > target/maven/test-classes, for example. How do I set the 
> "main" output
> > folder used for all build results (classes, test-classes, 
> site, source
> > generation, ...)? Setting just "directory" attribute in my POM  
> > (Maven docu
> > says: "The directory where all files generated by the build are  
> > placed") is
> > not working, so do I have to set all paths separately?
> >
> > Thanks for your hints,
> > Christoph.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message