maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amshoff Christoph, Köln" <Christoph.Amsh...@fja.com>
Subject [M2] Problem deploying to filesystem on remote server
Date Wed, 23 Aug 2006 12:50:29 GMT
Hi,

I'm new to Maven2 and trying to deploy my first JAR... alas without success
up to now.

We are running an internal repository using Maven-Proxy (using it as a proxy
to "central" and for hosting our own artifacts).
This is working well, and now I would like to put my JARs (snapshot version)
onto this server using the deploy goal with file system configuration.

In my POM, I configured the settings like this:

    <snapshotRepository>
      <id>central</id>
      <name>xxx</name>
      <url>file:///[a_server]/maven2-server/target/repo-local</url>
      <uniqueVersion>false</uniqueVersion>
    </snapshotRepository>

The output seems to be ok, it says "551 K uploaded", but the file has NOT
been copied. Even with enabled debug information (see below) I don't see any
problems... or is this "not adding permissions to wagon connection" telling
me anything? And yes, I have full access to the specified folder on the
remote computer.

Is file system deploy only working locally? 
What else should I use to deploy to Maven-Repo?

Any help is appreciated...

Thanks in advance,
Christoph.

--- snip ---
[INFO] [deploy:deploy]
[INFO] Retrieving previous build number from central
[DEBUG] repository metadata for: 'snapshot sss:foundation:4.3.2-SNAPSHOT'
could not be found on repository: central
[DEBUG] not adding permissions to wagon connection
Uploading:
file:///[a_server]/maven2-server/target/repo-local/xxx/yyy/4.3.2-SNAPSHOT/yy
y-4.3.2-SNAPSHOT.jar
<file:///[a_server]/maven2-server/target/repo-local/xxx/yyy/4.3.2-SNAPSHOT/y
yy-4.3.2-SNAPSHOT.jar> 
551K uploaded
[INFO] Retrieving previous metadata from central
[DEBUG] repository metadata for: 'artifact sss:foundation' could not be
found on repository: central
[INFO] Uploading repository metadata for: 'artifact sss:foundation'
[DEBUG] not adding permissions to wagon connection
[INFO] Retrieving previous metadata from central
[DEBUG] repository metadata for: 'snapshot sss:foundation:4.3.2-SNAPSHOT'
could not be found on repository: central
[INFO] Uploading repository metadata for: 'snapshot
sss:foundation:4.3.2-SNAPSHOT'
[DEBUG] not adding permissions to wagon connection
[INFO] Retrieving previous metadata from central
[DEBUG] project information for foundation 4.3.2-SNAPSHOT could not be found
on repository: central
[INFO] Uploading project information for foundation 4.3.2-SNAPSHOT
[DEBUG] not adding permissions to wagon connection
--- snap ---


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message