maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Cabasson <denis.cabas...@insee.fr>
Subject Re: Site deployment
Date Tue, 08 Aug 2006 14:48:24 GMT


apill wrote:
> 
> I have quoted a section of the site plugin documentation at the end of
> this post. The NOTE says that if I don't place a trailing slash at the
> end of the site deploy url, then child projects of this project will
> inherit the same location. I have tried this and it fails.
> 
> I have set the site deploy URL to
> scp://<path-to-website-on-server>/${artifactId}/${pom.version} in my
> parent pom.xml. In the child pom I haven't set anything, so I would
> expect the child to deploy to:
> scp://<path-to-website-on-server>/${child-artifactId}/${child- 
> pom.version}
> 
> instead it deploys to
> 
> scp://<path-to-website-on-server>/${child-artifactId}/${child- 
> pom.version}/${child-artifactId}
> 
> What can I do to solve this?
> 
> Thanks
> 

Looks like the documentation is not up to date... child-artifactId is always
appended to parent distributionManagement.url.

AFAIK, your only option there is to repeat in each of your pom the url of
the distributionManagement part.

Maybe you should fill a JIRA request to see this documentation fixed.

Denis.

-- 
View this message in context: http://www.nabble.com/Site-deployment-tf2072573.html#a5708020
Sent from the Maven - Users forum at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message