maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stéphane Bouchet <stephane.bouc...@knowesia.fr>
Subject Re: Multi-project site generation
Date Fri, 25 Aug 2006 08:45:33 GMT
Arnaud Bailly a écrit :
> Hi,
> I am trying to create site and deploy it for a multi-project
> package. In the coo (parent) pom, I define various reports to
> generate. The root also contains src/site/... tree with
> documentation. The site.xml does not contains reports sections. The
> pom is:
>
>
>  <reporting>
>   <plugins>
>    <plugin>
>     <groupId>org.apache.maven.plugins</groupId>
>     <artifactId>maven-project-info-reports-plugin</artifactId>
>    </plugin>
>    <plugin>
>     <groupId>org.apache.maven.plugins</groupId>
>     <artifactId>maven-javadoc-plugin</artifactId>
>    </plugin>
>    <plugin>
>      <groupId>org.codehaus.mojo</groupId>
>     <artifactId>surefire-report-maven-plugin</artifactId>
>    </plugin>
>
>    <plugin>
>    <groupId>org.codehaus.mojo</groupId>
>    <artifactId>cobertura-maven-plugin</artifactId>
>    </plugin>
>    
>    <plugin>
>     <groupId>org.codehaus.mojo</groupId>
>     <artifactId>jxr-maven-plugin</artifactId>
>    </plugin>
>    
>    <plugin>
>     <groupId>org.codehaus.mojo</groupId>
>     <artifactId>changes-maven-plugin</artifactId> 
>    </plugin>
>   </plugins>
>  </reporting>
>
>
> The modules each contain src/site/site.xml descriptor and POMs inherit
> from parent without any additional reports. Here is a sample site
> descriptor:
>
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <project name="JAutomata Core">
>  <skin>
>   <groupId>org.apache.maven.skins</groupId>
>   <artifactId>maven-stylus-skin</artifactId>
>   <version>1.0</version>
>  </skin>
>  <poweredBy>
>   <logo
>    name="Hosted on SourceForge.net"
>    href="http://sourceforge.net"       
>    img="http://sflogo.sourceforge.net/sflogo.php?group_id=170468&amp;type=1"/>
>   <logo
>    name="Build with Maven 2"
>    href="http://maven.apache.org"
>    img="images/logos/maven-feather.png"/>
>  </poweredBy>  
>  <body>
>   <links>
>    <item name="Maven 2" href="http://maven.apache.org/maven2/"/>
>   </links>
>
>   <menu name="JAuto" ref="parent" />
>   
>   <menu name="Standard reports" ref="reports" />
>
>  </body>
> </project>
>
> What happens is that 'mvn site' fails in parent site generation with:
>
> ....
> [INFO] Generate "Project Team" report.
> [INFO] Generate "Maven Surefire Report" report.
> [INFO] Generate "Cobertura Test Coverage" report.
> [INFO] Cobertura 1.7 - GNU GPL License (NO WARRANTY) - See COPYRIGHT file
>
> [ERROR] Error: data file /home/nono/projets/jautomata/jautomata-2.0/cobertura.ser does
not exist
>
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error during page generation
>
> Embedded error: Error rendering Maven report: Error in Cobertura Report generation: Unable
to generate Cobertura Report for project.
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 25 seconds
> [INFO] Finished at: Fri Aug 25 10:19:56 CEST 2006
> [INFO] Final Memory: 21M/38M
>
> This is "normal" as the parent does not contains any code. What
> puzzles me is that this generation process used to work when  child
> did not have descriptors !? 
>
> Help would be of course appreciated. 
>
>   
Hi,

there is an issue with cobertura-report.
See : http://jira.codehaus.org/browse/MCOBERTURA-38

It seems it is fixed in trunk, so try to build it from it.

Cheers,

Stéphane

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message