maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jimisola Laursen <li...@jimisola.com>
Subject NoClassDefFoundErrorfor a few classes that seems to be in the classpath
Date Sat, 10 Jun 2006 19:04:07 GMT

Hi!

Recently just migrated from Ant to Maven. It's a quite big project with a
main (parent) pom.xml and six-seven modules.

Everything compiles nicely for all modules, both main and test. However, I
have two modules, server and agent, were I keep getting NoClassDefFoundError
during executing of test cases.

 - server (NoClassDefFoundError for dbunit)
 - agent (NoClassDefFoundError for mocqurer and jaxen)

I've spent a lot of time trying to figure out the problem, but so far no
luck.
What is the best way from here to try solve this matter.

Known facts:

 - I have the same error whether I run Maven from command line or from
within Eclipse using m2eclipse
 - the libraries are included in Eclipse under "Maven2 Dependencies"
 - the libraries are listed in the classpath string when I run maven in
debug mode (-X)
 - I started out with scope = test, but left out scope completely.
 - junit-3.8.2.jar is needed by the tests as well and shows in classpath
just like the other three mentioned above
 - all tests depending only on plain JUnit succeeds

I really appreciate help on this matter since it a show stopper for me right
now.

Also, is there a way that I can have the "test run" outputed on
stdout/stderr? E.g. "mvn test -Dsurefire.show=all"

Regards,
Jimisola
--
View this message in context: http://www.nabble.com/NoClassDefFoundErrorfor-a-few-classes-that-seems-to-be-in-the-classpath-t1767398.html#a4810522
Sent from the Maven - Users forum at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message