maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <brett.por...@gmail.com>
Subject Re: [m2] Aggregated Javadoc dependency problems
Date Tue, 18 Apr 2006 14:42:31 GMT
This was reported recently by Jules. I intended to revisit it before
releasing the plugin.

If it isn't in JIRA already, would you mid filing it?

Thanks,
Brett

On 4/19/06, Wendy Smoak <wsmoak@gmail.com> wrote:
> The 'mvn javadoc:javadoc' command works fine with the latest plugin
> built from source and this in struts/action/trunk/pom.xml:
>
> <reporting>
>      <plugins>
>         <plugin>
>            <groupId>org.apache.maven.plugins</groupId>
>            <artifactId>maven-javadoc-plugin</artifactId>
>          </plugin>
>       </plugins>
>     </reporting>
>
> It drops into each module and builds the javadoc there.  However, if I
> add configuration and try to get aggregated Javadoc at the top level:
>            <configuration>
>              <aggregate>true</aggregate>
>            </configuration>
>
> It seems to build the aggregated Javadoc okay, but then when starts
> descending into each module it fails complaining "Cannot find
> symbol..." about things like commons-logging and the Servlet api.
> These are declared as dependencies at the module level.
>
> Am I configuring it correctly?
>
> Thanks,
> Wendy
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message