maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Freeman" <aaronwfree...@gmail.com>
Subject Re: Support for Multi-project Web Sites
Date Fri, 21 Apr 2006 05:24:39 GMT
I tried using ${modules} in the site.xml of my parent project, just
like you did, but it didn't seem to do anything for me either.


On 4/20/06, Ryan Wynn <bigwynnr@gmail.com> wrote:
> On 4/20/06, Ryan Wynn <bigwynnr@gmail.com> wrote:
> > On 4/20/06, Alexandre Poitras <alexandre.poitras@gmail.com> wrote:
> > > ${modules} should definitely work. What your site.xml file looks like?
> >
> > The parent site.xml is pretty basic.  The reports are showing but no
> > links to the modules.
> >
> > <?xml version="1.0" encoding="ISO-8859-1"?>
> > <project name="PCS">
> >        <bannerLeft>
> >                <name>PCS</name>
> >                <src>
> >                        images/pcs.png
> >                </src>
> >                <href>http://maven.apache.org/</href>
> >        </bannerLeft>
> >        <bannerRight>
> >                <src>
> >                        http://localhost/images/logo.png
> >                </src>
> >        </bannerRight>
> >        <body>
> >                <links>
> >                        <item name="Shale"
> >                                href="http://struts.apache.org/struts-shale/" />
> >                        <item name="Myfaces" href="http://myfaces.apache.org/"
/>
> >                </links>
> >                <menu name="PCS">
> >                        <item name="Home" href="index.html" />
> >                </menu>
> >
> >
> >                ${modules}
> >                ${reports}
> >
> >        </body>
> > </project>
> >
>
> the site plugin is 2.0-beta-4
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message