maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Joad" <tjo...@gmail.com>
Subject Re: Mvn eclipse and eclipse builders
Date Thu, 23 Feb 2006 10:16:44 GMT
Hi Alexandre


Here is my maven-eclipse plugin configuration;Nothing very special.
with mvn - Dwtpversion=R7 or wtpversion inside the pom.xml , I have
always the same poblems.
 <plugin>
          	<artifactId>maven-eclipse-plugin</artifactId>
            <version>2.1</version>
            <configuration>
              <workspace>c:\SODACP\WORKSPACE</workspace>
              <!--wtpversion>R7</wtpversion-->
               <!--executedProject>p3d</executedProject-->
               <!--project>p3d</project-->
              <classpathContainers>
                
<buildcommand>org.eclipse.jdt.launching.JRE_CONTAINER</buildcommand>
                
<buildcommand>org.eclipse.jst.server.core.container/org.eclipse.jst.server.tomcat.runtimeTarget/Apache
Tomcat v5.5</buildcommand>
                
<buildcommand>org.eclipse.jst.j2ee.internal.web.container/artifact</buildcommand>
               </classpathContainers>
               <buildcommands>
               <java.lang.String>org.eclipse.wst.common.modulecore.ComponentStructuralBuilder</java.lang.String>
               
<java.lang.String>org.eclipse.jdt.core.javabuilder</java.lang.String>
               
<java.lang.String>org.eclipse.wst.common.modulecore.ComponentStructuralBuilderDependencyResolver</java.lang.String>
               
<java.lang.String>org.hibernate.eclipse.console.hibernateBuilder</java.lang.String>
               
<java.lang.String>org.springframework.ide.eclipse.core.springbuilder</java.lang.String>
               
<java.lang.String>net.sourceforge.metrics.builder</java.lang.String>
                </buildcommands>
                <projectnatures>
                <projectnature>org.eclipse.jdt.core.javanature</projectnature>
                
<projectnature>org.eclipse.wst.common.modulecore.ModuleCoreNature</projectnature>
                
<projectnature>org.springframework.ide.eclipse.core.springnature</projectnature>
                
<projectnature>org.hibernate.eclipse.console.hibernateNature</projectnature>
                 <projectnature>net.sourceforge.metrics.nature</projectnature>
                 </projectnatures>
              </configuration>
            </plugin>

Errors i get under eclpise are
java.lang.ClassCastException:
org.eclipse.wst.common.componentcore.internal.resources.VirtualArchiveComponent
...

Errors running builder "Component Structural Dependency Resolver" on
project p3d.
...
Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
java.lang.ClassCastException:
org.eclipse.wst.common.componentcore.internal.resources.VirtualArchiveComponent

have you any informations about these errors ?

It's like a version problem.

I use jvm 1.4.2 maven 2.0.2 eclipse 3.1.1

Tom


2006/2/21, Alexandre Poitras <alexandre.poitras@gmail.com>:
> Try "mvn -Dwtpversion=R7 eclipse:eclipse" since you are using wtp. If
> it work you can move the configuration inside your pom.xml.
>
> On 2/21/06, Tom Joad <tjoad9@gmail.com> wrote:
> > Hi all,
> > We have an eclipse project R7 which began without maven managing
> > configuration i.e It is an  eclipse Dynamic web application and  all
> > dependencies are under WEB-INF/lib .the project uses spring and
> > hibernate frameworks.
> > We want to use maven to manage our lifecycle build from now, so I
> > create the pom file for the project with genuine configuration of
> > maven-eclipse-plugin. For example
> > I take exactly all classpathContainers.buildcommand values on the
> > non-maven-defined project  So when running mvn eclipse:eclipse  I get
> > the same .project file
> > My .wtpmodules file seems good , and so with .classpath
> >
> > I think that i didn't anything wrong but I get the following error
> > when eclipse builds the project.
> > Errors running builder "Component Structural Dependency Resolver".
> > I think that following errors  are direct consequence of it.
> > Eclipse doesn't compile my project no class files generate under the
> > targetpath  myeclipse project/.deployables/WEB-INF/classes and no
> > dependencies put under /myeclipse project/.deployables/WEB-INF/lib .
> >
> > Am i rignt to think that for instance the snippet
> > <dependent-module deploy-path="/WEB-INF/lib"
> > handle="module:/classpath/var/M2_REPO/quartz/quartz/1.5.0-RC1/quartz-1.5.0-RC1.jar">
> >       <dependency-type>uses</dependency-type>
> >     </dependent-module> is used by eclipse builders to populate
> > /myeclipse project/.deployables/WEB-INF/lib .
> >
> > I already spend 2 days , googling  (curiously with my error criteria ,
> > there is no more the twenty results), reading docs etc. to try to
> > resolve this problem.
> > maven build works fine and it is the last (I wish) , so that i can say
> > that we definitively adopt maven.
> >
> > Thanks for all helps,
> > Tom
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > For additional commands, e-mail: users-help@maven.apache.org
> >
> >
>
>
> --
> Alexandre Poitras
> Qu├ębec, Canada
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message