maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukas Theussl <ltheu...@apache.org>
Subject Re: [M 1.1b1] Maven-Reports: Encoding Problems
Date Thu, 24 Nov 2005 21:33:53 GMT
For this you probably have to set the maven.compile.encoding option of 
the java plugin.

HTH,
Lukas


Gisbert Amm wrote:
> With the described workaround I face another problem:
> 
> In some of our sources there is code to replace non-ASCII characters 
> like that:
> 
> for(int i=0; i < length; i++) {
>             char c = input.charAt(i);
>             switch(c) {
>               case 'Ä':     builder.append("Ae"); break;
>               case 'ä':     builder.append("ae"); break;
>               case 'Ö':     builder.append("Oe"); break;
>               case 'ö':     builder.append("oe"); break;
>               case 'Ü':     builder.append("Ue"); break;
>               case 'ü':     builder.append("ue"); break;
>               case 'ß':     builder.append("ss"); break;
>               ...
>               default:      builder.append(c);
>             }
> 
> When I set the LANG variable to de_DE.utf8, the compiler finds \ufffd 
> instead of Ä,ä,Ö,ö,Ü,Ü,ß and stops with a "duplicate case label" error.
> 
> Is there a way to get around this?
> 
> Thanks in advance for your help,
> Gisbert Amm
> 
> 
> Gisbert Amm wrote:
> 
>> I finally found something I consider a workaround for the checkstyle 
>> report (I already use the 3.0-SNAPSHOT of the plugin) and the xdocs:
>>
>> I'v changed the locale settings on my SuSE 9.1 system like that
>>
>> export LANG=de_DE.utf8
>> export LC_CTYPE=de_DE.utf8
>>
>> (setting of LC_CTYPE was necessary aswell)
>>
>> and set the following Maven properties:
>>
>> maven.docs.outputencoding=UTF-8
>> maven.xdoc.locale.default=de_DE.utf8
>>
>> Now the German umlauts are displayed correctly within the checkstyle 
>> report and the documents generated out of the xdocs (like index.xml). 
>> However, other reports like Javadoc, Source Xref and Test Xref still 
>> suffer from wrong encoded characters.
>>
>> Regards,
>> Gisbert Amm
>>
>> Lukas Theussl wrote:
>>
>>> On Linux you also have to set the system encoding explicitly,
>>> see 
>>> http://maven.apache.org/maven-1.x/reference/plugins/xdoc/faq.html#problems-unicode

>>>
>>> Arnaud HERITIER wrote:
>>>
>>>> For checkstyle it fixes only the locale.
>>>> It doesn't help for the encoding :-(
>>>>
>>>>> -----Message d'origine-----
>>>>> De : Lukas Theussl [mailto:ltheussl@apache.org] Envoyé : mercredi 
>>>>> 16 novembre 2005 00:03
>>>>>
>>>>> For the checkstyle plugin this should be fixed in the current 
>>>>> 3.0-SNAPSHOT (see http://jira.codehaus.org/browse/MPCHECKSTYLE-39 
>>>>> ), but it might still be a problem for other plugins.
>>>>>
>>>>> Gisbert, which plugins/reports do you have problems with?
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message