maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Böckling <michael.boeckl...@giniality.com>
Subject [m2] How to: restrict allowed dependency versions
Date Tue, 22 Nov 2005 16:48:23 GMT
Hi people,

I'd like to know if there is a way to impose restrictions on the 
versions of the referenced dependencies.
In big companies, you often have a specific set of third party library 
versions that are "approved" for usage in company projects, and other 
versions are not allowed. More often than not, there are several such 
"version-sets", because there is a strict lifecycle-management in place. 
Does anybody have an idea as to how this could be accomplished with 
Maven 2? Separate repositories for each version-set come to my mind, but 
that seems rather cumbersome to me.

Thanks for any input on that matter,
Michael Böckling

-- 
Giniality AG - Michael Böckling; Steinenberg 21, CH-4051 Basel
P: +41 61 226 99 63 - F: +41 61 226 99 69
michael.boeckling@giniality.ch; http://www.giniality.com/



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message