maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luca Gmail" <luca.rasc...@gmail.com>
Subject RE: problem creating eclipse project
Date Thu, 17 Nov 2005 10:01:02 GMT
Thnak you Martijn,
the problem is subsequent to the bug, infact before import simple.servlet in
eclipse I followed instrucions in http://jira.codehaus.org/browse/MNG-1433
and eclipse see M2_REPO variable. 
But I don't know why eclipse tell " Path '/' must denote location inside
project simple-servlet."

Maybe eclipse is not able to address the entries like this in the .classpath
file created by mvn eclipse:eclipse plugin 
<classpathentry kind="var" path="M2_REPO/mydependences.jar />
???

If I read the string M2_REPO without any escape character I should not be
able to distinguish it from a directory! Maybe :-)

Tnx,
Luca

-----Original Message-----
From: mdebruijn@novumsoftware.nl [mailto:martijn.de.bruijn@gmail.com] 
Sent: giovedì 17 novembre 2005 10.17
To: users@maven.apache.org
Subject: RE: problem creating eclipse project

Luca,
The eclipse:add-maven-repo goal contyains a bug. The M2_REPO variable is
created in the wrong directory.
If you use:
mvn eclipse:add-maven-repo -Declipse.workspace=c:\myWorkspace
the variables will be created in c:\myWorkspaceX
The X is added to the workspace dir. This is a bug.
Copy the file from c:\myWorkspaceX to c:\myWorkspace and your problem is
solved.

Martijn de Bruijn


-----Oorspronkelijk bericht-----
Van: Luca Gmail [mailto:luca.rasconi@gmail.com]
Verzonden: Thursday, November 17, 2005 10:01 AM
Aan: 'Maven Users List'
Onderwerp: problem creating eclipse project


Hi all,

i created a simple project starting from a my archetype (the name is
simple-servlet). After that I'd like to create an eclipse project so inside
the project root directory I created the variable M2_REPO and executed mvn
eclipse:eclipse. From eclipse I imported the project (File >Import >Existing
Projects into Workspace).

Now I see my eclipse project with this error:

Path '/' must denote location inside project simple-servlet.



Somebody can help me address this error?



Thanks a lot,

Luca


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message