maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rubén Barroso <ruben.mail...@gmail.com>
Subject Re: [m2] Missing properties in schemaexport
Date Thu, 24 Nov 2005 09:17:27 GMT
Could you say me how to install & configure it? I can see it in the
plugin matrix, but I'm not able to find the steps to configure it.

Thanks again.

2005/11/24, Edwin Punzalan <epunzalan@exist.com>:
>
> Have you tried using the hibernate plugin directly instead of calling
> ant-run to call hibernate ?
>
>
> Rubén Barroso wrote:
>
> >Hello, I've been trying to use hibernate plugin in maven 2, but it
> >doesn't work me. I've tried to achieve the same goal (schemaexport)
> >with the following code:
> >
> >         <plugin>
> >          <groupId>org.apache.maven.plugins</groupId>
> >                   <artifactId>maven-antrun-plugin</artifactId>
> >                   <executions>
> >                      <execution>
> >                      <phase>package</phase>
> >                      <configuration>
> >                         <tasks>
> >               <echo>dialect: ${hibernate.dialect}</echo>
> >               <taskdef name="schemaexport"
> >                     classname="org.hibernate.tool.hbm2ddl.SchemaExportTask">
> >                                       <classpath>
> >                                               <path refid="maven.dependency.classpath"/>
> >                                       </classpath>
> >                               </taskdef>
> >                               <mkdir dir="target/schema"/>
> >                               <schemaexport
> >                                       quiet="no"
> >                                       text="no"
> >                                       drop="no"
> >                                       delimiter=";"
> >                                       output="target/schema/create-tables.sql">
> >                                       <fileset dir="target/classes" includes="**/*.hbm.xml"/>
> >                               </schemaexport>
> >
> >              </tasks>
> >            </configuration>
> >            <goals>
> >              <goal>run</goal>
> >            </goals>
> >          </execution>
> >        </executions>
> >      </plugin>
> >
> >When I execute 'mvn package', it says me that I must set the property
> >'hibernate.dialect'. On the other hand, <echo> works fine!!! Any
> >ideas??
> >
> >Thanks in advance
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> >For additional commands, e-mail: users-help@maven.apache.org
> >
> >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message