maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCrann" <Michael.McCr...@macquarie.com>
Subject RE: Réf. : RE: [m2] Maven release plugin and CVS: bug?
Date Wed, 19 Oct 2005 22:02:15 GMT
Fabrice,

After deleting the .cvspass and running release:prepare, can you run CVS commands from the
command line without access problems?

i.e. is the release:prepare generated .cvspass file valid?

Also, it would be good if we could somehow see the CVS command being executed by release:prepare,
but I don't know how to do this. Anyone any suggestions?

Michael



-----Original Message-----
From: fabrice.belingard@mpsa.com [mailto:fabrice.belingard@mpsa.com]
Sent: Thursday, 20 October 2005 12:36 AM
To: Maven Users List
Subject: Réf. : RE: [m2] Maven release plugin and CVS: bug?






Hi David,

I use CVSNT indeed, but as I provided my password in the SCM connection, it
seems that the release:prepare goal creates by itself the ".cvspass" with
the good entry.
And I also tried with a truely valid ".cvspass" (that works with other
plugins, m1 plugins for instance), it still doesn't work. That's why I run
out of ideas as of what I can do to make it work...

Best Regards / Cordialement,
Fabrice BELLINGARD
DINQ/DSIN/INSI/EATE/IDVS/AIDV
(+33) (01 61) 45 15 91  -  fabrice.belingard@mpsa.com


                                                                           
             David Jackman                                                 
             <David.Jackman@f                                              
             astsearch.com>                                           Pour 
                                       Maven Users List                    
             19/10/2005 16:14          <users@maven.apache.org>            
                                                                        cc 
                                                                           
                 Veuillez                                            Objet 
                répondre à             RE: [m2] Maven release plugin and   
             Maven Users List          CVS: bug?                           
             <users@maven.apa                                              
                 che.org>                                                  
                                                                           
                                                                           
                                                                           
                                                                           




What do you see when you run cvs -version from the command line?  If you're
running some version of CVSNT, then doing a cvs login from the command line
won't create the necessary ~/.cvspass file that the Maven SCM operations
will need.  (Because CVSNT stores the passwords in the registry instead of
a file.)  There are some web pages around that talk about this issue.  If
that's what you're seeing, I wrote a utility some time back that extracts
passwords from the registry and creates a .cvspass file with them.

..David..


-----Original Message-----
From: fabrice.belingard@mpsa.com [mailto:fabrice.belingard@mpsa.com]
Sent: Wednesday, October 19, 2005 4:15 AM
To: users@maven.apache.org
Subject: RE: [m2] Maven release plugin and CVS: bug?





Michael,

thanks for your answer. Unfortunately, although I've followed every step
you gave to me, I still get the same error:

********************************************************************************************

...
[INFO] [release:prepare]
[INFO] Verifying there are no local modifications ...
Provider message:
The cvs command failed.
Command output:
cvs update: Empty password used - try 'cvs login' with a real password

cvs [update aborted]: authorization failed: server localhost rejected
access to C:\fabPlateformeIntegration\cvsAppliExempleTest for user fabrice

[INFO]
----------------------------------------------------------------------------

[ERROR] BUILD ERROR
[INFO]
----------------------------------------------------------------------------

[INFO] An error is occurred in the status process.

Embedded error: Error!
...
********************************************************************************************


Maybe the problem comes from somewhere else... But that's weird because
when I connect to CVS via the command line, my user/password account is
correct and I'm not rejected.


Best Regards / Cordialement,
Fabrice BELLINGARD
DINQ/DSIN/INSI/EATE/IDVS/AIDV
(+33) (01 61) 45 15 91  -  fabrice.belingard@mpsa.com



             Michael McCrann
             <Michael.McCrann
             @macquarie.com>                                          Pour
                                       fabrice.belingard@mpsa.com,
             19/10/2005 07:16          users@maven.apache.org
                                                                        cc

                                                                     Objet
                                       RE: [m2] Maven release plugin and
                                       CVS: bug?










Fabrice,

Here is something else that is worth trying:

- Make sure that you are using M2 RC. (I deleted my local repository after
installing the RC, to ensure my installation was completely fresh)

Say, for example your Maven SCM URL is:

scm:cvs:pserver:<user>:<password>@<cvs-server>:<cvs-repository-path>:module

- Delete your .cvspass file.

This should be in your home directory ('c:\Documents and Settings' for me)

- Run the CVS login command:

cvs -d:pserver:<user>@<cvs-server>:<cvs-repository-path> login

- Run the release:prepare goal.

Michael

-----Original Message-----
From: fabrice.belingard@mpsa.com [mailto:fabrice.belingard@mpsa.com]
Sent: Tuesday, 18 October 2005 5:55 PM
To: Michael McCrann
Subject: RE: [M2 RC] problems with release:perform






Hi Michael,

This release plugin seems to be quite tricky... I still haven't succeeded
in making the prepare goal working! Could you please show me how your pom
looks like so that I can try to find what's wrong with mine?

Thanks a lot in advance! :o)

Best Regards / Cordialement,
Fabrice BELLINGARD
DINQ/DSIN/INSI/EATE/IDVS/AIDV
(+33) (01 61) 45 15 91  -  fabrice.belingard@mpsa.com



             Michael McCrann
             <Michael.McCrann
             @macquarie.com>                                          Pour
                                       Maven Users List
             18/10/2005 08:34          <users@maven.apache.org>
                                                                        cc

                 Veuillez                                            Objet
                répondre à             RE: [M2 RC] problems with
             Maven Users List          release:perform
             <users@maven.apa
                 che.org>








Hi,

In attempt to find a solution to the my release:perform problem, I checked
out the trunk version and built maven using the m2-bootstrap-all.bat
script.

I ran the release:perform again and got the error below.

Ignoring the m2 deprecated message! could the problem be something to do
with '/' in the working directory:
c:\michaels_projects\transact\target/checkout?

Michael

[DEBUG] Configuring mojo
'org.apache.maven.plugins:maven-release-plugin:2.0-beta-3:perform' -->
[DEBUG]   (f) basedir = c:\michaels_projects\transact
[DEBUG]   (f) goals = deploy:deploy
[DEBUG]   (f) interactive = true
[DEBUG]   (f) project = org.apache.maven.project.MavenProject@c4635b8b
[DEBUG]   (f) workingDirectory =
c:\michaels_projects\transact\target/checkout
[DEBUG] -- end configuration --
[INFO] [release:perform]
[INFO] Checking out the project to perform the release ...

THE m2 COMMMAND IS DEPRECATED - PLEASE RUN mvn INSTEAD

The directory name is invalid.
[INFO]
----------------------------------------------------------------------------



[ERROR] BUILD ERROR
[INFO]
----------------------------------------------------------------------------



[INFO] Result of m2 execution is: '1'. Release failed.
[INFO]
----------------------------------------------------------------------------



[DEBUG] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: Result of m2
execution is: '1'. Release failed.


NOTICE
This e-mail and any attachments are confidential and may contain copyright
material of Macquarie Bank or third parties. If you are not the intended
recipient of this email you should not read, print, re-transmit, store or
act in reliance on this e-mail or any attachments, and should destroy all
copies of them. Macquarie Bank does not guarantee the integrity of any
emails or any attached files. The views or opinions expressed are the
author's own and may not reflect the views or opinions of Macquarie Bank.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org






---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message