maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <brett.por...@gmail.com>
Subject Re: How to set a plugin's prefix?
Date Mon, 05 Sep 2005 22:27:32 GMT
Take a look at maven-core-it/it0031 - this verifies that a different groupId 
works, and shows the appropriate settings.xml for the goal.

On 9/6/05, Wendell Beckwith <wbeckwith@gmail.com> wrote:
> 
> I have since updated to r278671 and rebuilt maven to no avail. Now 
> currently I'm only updating and building maven-compoments, but do I need to 
> updated and build any other components?
> 
> Wb
> On 9/4/05, Brett Porter <brett.porter@gmail.com> wrote:
> > 
> > It's possible that there was a bug when the plugins.xml file could not 
> > be found remotely.
> > 
> > The code has been rewritten recently (it now doesn't use plugins.xml but 
> > maven-metadata-*.xml). What SVN rev is your m2 build from?
> > 
> > - Brett
> > 
> > On 9/5/05, Wendell Beckwith < wbeckwith@gmail.com> wrote:
> > > 
> > > Also here is a copy of a run using the groupId and using the prefix 
> > > where it
> > > fails.
> > > 
> > > 
> > > E:\dev\workspace\runtime>m2
> > > com.intervoice.maven.plugins:maven-hello-plugin:hello
> > > [INFO] maven-hello-plugin: using locally installed snapshot 
> > > [INFO]
> > > 
> > > ----------------------------------------------------------------------------
> > > [INFO] Building Runtime
> > > [INFO] task-segment: [
> > > com.intervoice.maven.plugins:maven-hello-plugin:hello]
> > > [INFO]
> > > ----------------------------------------------------------------------------

> > > 
> > > [INFO] [hello:hello]
> > > *** Before ***
> > > [INFO] Hello Configured Maven
> > > *** After ***
> > > [INFO]
> > > 
> > > ----------------------------------------------------------------------------
> > > [INFO] BUILD SUCCESSFUL
> > > [INFO]
> > > 
> > > ----------------------------------------------------------------------------
> > > [INFO] Total time: < 1 second
> > > [INFO] Finished at: Sun Sep 04 11:34:37 CDT 2005
> > > [INFO] Final Memory: 1M/3M
> > > [INFO]
> > > ----------------------------------------------------------------------------

> > > 
> > > 
> > > E:\dev\workspace\runtime>m2 hello:hello
> > > [INFO] Retrieving plugins.xml (plugin mappings) for group: '
> > > com.intervoice.maven.plugins'
> > > [WARNING] Cannot resolve plugin-mapping metadata for groupId:
> > > com.intervoice.maven.plugins - IGNORING.
> > > [INFO] Retrieving plugins.xml (plugin mappings) for group: '
> > > org.apache.maven.plugins'
> > > [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local =
> > > '474e017fdc
> > > f6842eb0a46087c31c1bc610b1372d'; remote = 
> > > '908ceb9e48e5e6ad4b0b262d62f241a40bee4
> > > 603' - IGNORING
> > > [INFO] Refreshing plugin mapping metadata; looking for plugin with 
> > > prefix:
> > > 'hello'.
> > > [WARNING] Cannot resolve plugin-mapping metadata for groupId:
> > > org.apache.maven.plugins - IGNORING.
> > > [INFO] maven-hello-plugin: checking for updates from central-plugins
> > > [INFO] Retrieving release information for maven-hello-plugin
> > > Downloading:
> > > 
> > > http://repo1.maven.org/maven2/plugins/org/apache/maven/plugins/maven-hello-plugin/RELEASE/maven-hello-plugin-RELEASE.pom
> > > [WARNING] Unable to get resource from repository
> > > http://repo1.maven.org/maven2/plugins
> > > [WARNING]
> > > ***** Using defaults for missing POM
> > > org.apache.maven.plugins:maven-hello-plugin:pom:RELEASE *****
> > > 
> > > Downloading:
> > > 
> > > http://repo1.maven.org/maven2/plugins/org/apache/maven/plugins/maven-hello-plugin/RELEASE/maven-hello-plugin-RELEASE.jar
> > > [WARNING] Unable to get resource from repository
> > > http://repo1.maven.org/maven2/plugins
> > > [INFO] Cannot find mojo descriptor for: 'hello:hello' - Treating as
> > > non-aggregator.
> > > [INFO]
> > > ----------------------------------------------------------------------------

> > > 
> > > [INFO] Building Runtime
> > > [INFO] task-segment: [hello:hello]
> > > [INFO]
> > > 
> > > ----------------------------------------------------------------------------
> > > Downloading:
> > > 
> > > http://repo1.maven.org/maven2/plugins/org/apache/maven/plugins/maven-hello-plugin/RELEASE/maven-hello-plugin-RELEASE.jar
> > > [WARNING] Unable to get resource from repository
> > > http://repo1.maven.org/maven2/plugins
> > > [INFO]
> > > 
> > > ----------------------------------------------------------------------------
> > > [INFO] BUILD FAILURE
> > > [INFO]
> > > ----------------------------------------------------------------------------

> > > 
> > > [INFO] Main Error:
> > > Mojo could not be found - check that the goal name is correct
> > > org.apache.maven.plugins:maven-hello-plugin:RELEASE:maven-plugin
> > > 
> > > from the specified remote repositories:
> > > http://repo1.maven.org/maven2/plugins
> > > 
> > > Root error:
> > > Unable to download the artifact from any repository
> > > [INFO]
> > > 
> > > ----------------------------------------------------------------------------
> > > [INFO] Total time: < 1 second 
> > > [INFO] Finished at: Sun Sep 04 11:35:06 CDT 2005
> > > [INFO] Final Memory: 1M/3M
> > > [INFO]
> > > 
> > > ----------------------------------------------------------------------------
> > > 
> > > E:\dev\workspace\runtime>
> > > 
> > > Wb
> > > 
> > > On 9/4/05, Wendell Beckwith <wbeckwith@gmail.com> wrote:
> > > >
> > > > Yes, the com/intervoice/maven/plugins/plugins.xml has the following: 
> > > 
> > > >
> > > > <metadata> 
> > > > <groupId>com.intervoice.maven.plugins</groupId>
> > > > <plugins>
> > > > <plugin>
> > > > <prefix>hello</prefix>
> > > > <artifactId>maven-hello-plugin</artifactId> 
> > > > </plugin>
> > > > </plugins>
> > > > </metadata>
> > > >
> > > > Wb
> > > 
> > > 
> > 
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message