maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <adam.ma...@cyberspaceroad.com>
Subject [m2 beta-1] dependency resolution
Date Sun, 18 Sep 2005 20:30:10 GMT
I just upgraded from the alpha-3 nightly from svn to the beta-1 release.

I'm using maven-xdoclet-plugin and I have the following in my pom:

   <pluginRepositories>
     <pluginRepository>
       <id>Neonics</id>
       <url>http://www.neonics.com/maven2/</url>
     </pluginRepository>
   </pluginRepositories>

so that 'm2 -U package' resolved the latest snapshot of the xdoclet 
plugin. Once maven had downloaded the latest snapshot (20050918), I took 
out the reference to the repository.

Now though m2 resolves the dependency to a previous snapshot

[DEBUG] resolveMetaData: 
org.apache.maven.plugins:maven-xdoclet-plugin:pom:1.0-SNAPSHOT: Skipping 
disabled repository central (http://repo1.maven.org/maven2)
[DEBUG] resolveMetaData: 
org.apache.maven.plugins:maven-xdoclet-plugin:pom:1.0-SNAPSHOT: Skipping 
disabled repository central (http://repo1.maven.org/maven2)
[DEBUG] maven-xdoclet-plugin: resolved to version 1.0-20050813.152803-4 
from local repository


For some reason maven didn't upgrade 
maven-xdoclet-plugin-1.0-SNAPSHOT.version.txt which still names the old 
snapshot.

I changed this by hand but shouldn't this happen automatically?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message