maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel ." <constant...@soon.com>
Subject Re: Downloading artifacts fails with a 301
Date Mon, 17 Jan 2005 22:21:14 GMT
Turns out I wrongly accused the FAQ entry -  it states that http://www.ibiblio.org/maven is
the repo mirror not .com as I have in my build.properties. 
 
I have corrected the entry in my settings and artifacts can now be downloaded.  Though I still
think maven should follow the link forward as the http spec 
recommends... 
 
 
For the sake of posterity, if you get something like 
 
Error retrieving artifact from [http://www.ibiblio.com/maven/velocity-dvsl/jars/velocity-dvsl-0.45.jar]:
java.io.IOException: Unknown error downloading; status code was: 
301 
WARNING: Failed to download velocity-dvsl-0.45.jar. 
The build cannot continue because of the following unsatisfied dependencies: 
velocity-dvsl-0.45.jar 
 
get the file with wget or something, check the link that gets followed and update your maven.repo.remote
setting accordingly. 
 
 
Daniel 
 
 
 
Hello,    
   
I've just upgraded to 1.0.2 and am unable to build anything as downloading artifacts \ 
from Ibiblio ( http://www.ibiblio.com/maven/ )fails with a status code of 301, ie  \ 
Permanently Moved.    
Is it intended that maven will do a link-rewrite or do we have to correct it by \ 
altering out remote repo setting?    
If we need to change the remote repo setting, what should it be set to, as the Maven \ 
FAQ states that http://www.ibiblio.com/maven/ should be good?    
Thanks  
Daniel  
-- 
___________________________________________________________
Sign-up for Ads Free at Mail.com
http://promo.mail.com/adsfreejump.htm


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message